[SOLVED] The Easy Debug Red Light is on on my MSI B450 Tomahawk Max II but the PC seems to be working fine.

Dec 11, 2021
10
0
10
0
The Easy Debug Red Light for CPU is on on my MSI B450 Tomahawk Max II but the PC seems to be working fine. I have a Ryzen 5 5600x on it. It would normally require a BIOS flash update but the motherboard came with a sticker that said "Ryzen 5000 ready" so I assume that has already been taken care of. I mean, it must have, I was able to post and install Windows and everything.

Is it a false alarm? Do I ignore it? Can I turn it off?
 
The Easy Debug Red Light for CPU is on on my MSI B450 Tomahawk Max II but the PC seems to be working fine. I have a Ryzen 5 5600x on it. It would normally require a BIOS flash update but the motherboard came with a sticker that said "Ryzen 5000 ready" so I assume that has already been taken care of. I mean, it must have, I was able to post and install Windows and everything.

Is it a false alarm? Do I ignore it? Can I turn it off?
Well, i suggest you to update the bios to the latest, and set all the settings (like xmp, and other stuff you did on the bios) back after you updated the bios to the latest.
 
Reactions: kurdtnz
The Easy Debug Red Light for CPU is on on my MSI B450 Tomahawk Max II but the PC seems to be working fine. I have a Ryzen 5 5600x on it. It would normally require a BIOS flash update but the motherboard came with a sticker that said "Ryzen 5000 ready" so I assume that has already been taken care of. I mean, it must have, I was able to post and install Windows and everything.

Is it a false alarm? Do I ignore it? Can I turn it off?
Well, i suggest you to update the bios to the latest, and set all the settings (like xmp, and other stuff you did on the bios) back after you updated the bios to the latest.
 
Reactions: kurdtnz
Dec 11, 2021
10
0
10
0
I checked the BIOS version I had and it was indeed an earlier version than the one that added optimized support for Ryzen 5000 (silly sticker). So, for anyone in the same situation, I followed MSI's instructions here: https://us.msi.com/support/technical_details/MB_BIOS_Update and updated the BIOS. Red warning light has now disappeared!

Cheers!

P.S.: I avoided the 63 version because it says beta and I am not using Windows 11 anyway. I choose the H50.
 

ASK THE COMMUNITY