[SOLVED] Unable to update bios, maybe bad file. ROG STRIX X470-F GAMING


May 7, 2017
Hello everyone. I have never updated a bios before, but I am doing lots of research as I go
I am attempting to update my bios and running into problems. I have a working theory that my problems are somehow caused by bad downloads but i don't know how to deal with this, and could do with a third party to help out

My motherboard is the

Now I already know the first rule of updating your bios is don't. Unless you really have to

I have just purchased a new CPU, the AMD Ryzen 9 5950 X

Pretty new i think, this thing cost a packet. The instructions include a warning to check that my bios is compatible, so I checked and it's not. I'm 99% certain that i will need to update my bios in order to use this.

That said, I have not tried installing the new cpu yet. I would rather not unless im sure, since at the very least i'd have to use some thermal paste to install it, and then more to switch back to the current cpu if that fails. Maybe it'd work if i went ahead and installed it now, but im not keen to take that risk

My reasons for believing a bios update is needed:

CPU-Z screenshot showing im running version 4024

View: https://i.imgur.com/eV6S5u2.png

This page on the motherboard manufacturer's website, listing compatible cpus:

My new cpu is down near the bottom, and note that it states there, compatibility is validated since bios version 5809

View: https://i.imgur.com/xrg4Am7.png

I am not entirely clear whether that means i need 5809 to make everything not crash and burn, or whether 5809 just resolves some bugs and makes it perfectly stable

so, through this page i can download the latest bios for my board.


It gives me version 6024, which comes in a 15mb zip file containing two things: a .cap file which i assume is the main thing, and BIOSrenamer.exe
I have no idea what that last one is.

Something that really sets alarm bells ringing though, is that unzipping the file gives a warning:
View: https://i.imgur.com/TA9y8i7.png

"Warnings: There are some data after the end of the payload data"
I don't know exactly what this means, but it seems to indicate that something might be wrong with the download. I have repeated the download several times, and also tried an older bios version, it keeps happening

So according to the asus support page: https://www.asus.com/support/FAQ/1044348/
There are two main ways to update the bios.
Trying the easiest one first, the software method using EZupdate. I got that all setup and tried the autoupdate. But it just gives the bland error: "There is no need to update the environment."
I can only guess that this means the current bios version is fine for the current cpu, but it doesnt know i want to update, and offers no options to do that

There's a manual file selection dialog there too, so I try that and select the downloaded cap file from the aforementioned zip, but this throws the following error
"The model of the BIOS image doesn't match the BIOS ROM currently present."

I'm certain I picked the right motherboard, so the only thing i can conclude here is the files being damaged somehow
I tried the older version i downloaded too, same result.

So in the interest of completeness, i've also tried the offline install. Using the EZflash utility in the bios menu during boot, and putting the bios files on a memory stick. I try to install them from there but i'm getting a similar error

"Selected file is not a proper bios"

I even managed to use the offline internet installation. This detected and downloaded version 5809 (which is the exact one I needed in the first place!) Only to then error out with it not being a proper bios
I just can't win.

In my research I did uncover one case of someone mentioning incremental updates, so I decided to try that. I downloaded about the last 20 bios releases for my board and tested them all through the EZupdate. Some of them worked! The earliest ones. Among those, I found the highest working version, which was 4602, and installed that.
It went through a few steps, restarted a few times, and was successful, i'm now running on bios 4602, see?
View: https://i.imgur.com/eJ45Xm4.png

My hope was that this would act as a stepping stone to later updates, but unfortunately nothing has changed. Every version higher than this still throws all the errors described above, and this version is not sufficient for my CPU

So I appear to have hit a wall. Please help!


May 7, 2017
Can I ask, as your motherboard doesnt have BIOS flash, how are you updating the BIOS, do you have a previous generation cpu?
It doesn't have bios flash? I'm not sure what you mean
In the tools section of the bios menu, there's an EZflash option which allows me to pick a bios file either from storage media, or to connect to the internet. I've used it as described above

I've had no luck with those options, but the one I did use for the incremental update attempt was the EZupdate tool in asus AI suite 3

The CPU I am currently using is a ryzen 7 2700 X
It's pretty good but I wanted to upgrade to something even grander for high end gaming


May 7, 2017
Should be able to go 5007, 5216, 5601, 5809, 5854, 6024 using the easyflash. Use the tool in bios not AiSuite as that has issues until you get past 5601
wow, thats amazing.
This is going to be a pain to do but ill try it and report back later tonight. You'll definitely be awarded best answer if this works out!


It's all in looking at the bios support page and paying attention to the bios notes. 5601 even says it fixes an issue with AiSuite. Being as it doesn't elaborate, assume that that includes the AiSuite easyflash 😁


May 7, 2017
Should be able to go 5007, 5216, 5601, 5809, 5854, 6024 using the easyflash. Use the tool in bios not AiSuite as that has issues until you get past 5601
Hooray, it is done!
View: https://i.imgur.com/7nFxAGv.png

I didn't end up needing to do all those steps, i skipped a few. I did
then 5601
and then 6024 from within the ezupdate
(and of course the 4602 from earlier came before all of these)

In all cases i used the biosrenamer so the file each time was called SX470FG.CAP

Great advice, thank you!


Feb 20, 2008
I followed the process and updated from 5837,5843,5851,5854,5861 and then 6024. All worked until 6024. I have tried 3 times and 6024 is not stable and will boot to windows only one time. Any reboot or restart will cause the bios not to load. after the 3rd reboot you can get to window then repeat and the PC and AMD GPU driver crashes. DDU many times and reinstalled chipset and GPU driver. Had to downgrade to 5861.

CPU 3700x Thinking of updating to 5800x3d, reason to update bios
32 GB 3200 ram
6900xt Red Devil Ultimate