Question When Starting my New build motherboard lights up, nothing else.

Jul 24, 2020
6
0
10
0
Hi, im fairly new to building PCs. My current PC that im building, when plugged in, imedietly the case and motherboard light up as well as the fan controller in the case. Nothing else turns on or off when pressing power button, not even the fans in the case turn on. I don't believe I hear a fan from the power supply at all. Is this the power supply? Did I mess up at all?

Build:

Intel i7-10700K

Geforce GTX 2080 Super 8Gb

32x2 GBs Gskill Ripjaws 2666Mhz

Asus ROG STRIX Z-490-E Gaming

NZXT Kraken X73 73.11 CFM

NZXT 710i ATX

Samsung 970 Evo 500G

Corsair RM 850 W 80+ Gold


Anything would be greatly appreciated! :)

Here is the images if you want.
View: https://imgur.com/a/2tNkuFM
 

jasonf2

Reputable
Oct 11, 2015
129
25
4,720
3
Did you plug the power switch from the case to the header on the motherboard? They will light up under power, but until the switch is activated they wont post. PSUs fans don't spin unless they get hot on good psus.
 
Jul 24, 2020
6
0
10
0
Did you plug the power switch from the case to the header on the motherboard? They will light up under power, but until the switch is activated they wont post. PSUs fans don't spin unless they get hot on good psus.
I believe I did, you mean the plug with the +pled and -pled?
 

jasonf2

Reputable
Oct 11, 2015
129
25
4,720
3
I believe I did, you mean the plug with the +pled and -pled?
Yes. Make sure that it is positioned correctly because they usually aren't dummy plugs and if inverted the power switch will be on the wrong side. Not sure from the picture but pin 1 on a ribbon cable is the one that is marked (usually white or red).
 

jasonf2

Reputable
Oct 11, 2015
129
25
4,720
3
If the first image is the connection the breakout cable it should work. I also believe that the F_Panel connector can plug directly into the left hand of the header on the board. Images are kind of bury but is there a bent pin on the header? The fifth top position, from the left moving right should be blank. It looks like you may have there is something there. If it is bent out that is the ground pin from your power switch. Looking at the F_Panel plug it looks like it will self orientate. I would make sure no pins are bent and plug it in directly to the left side of the header.
 

ASK THE COMMUNITY

TRENDING THREADS