[SOLVED] Windows 10 Disk Active 100%

Dulshan

Reputable
Jun 12, 2015
21
1
4,510
1
So I'm getting this Disk Usage 100% since about a month for about 5 - 10 mins after bootup and randomly. Computer is completely unusable during this times. No process is consuming disk resources (0% I/O) . I've tried everything on the internet except Clean installing windows, reseting and System restore. Please don't suggest me to do these I hate it. Unless there's nothing else to be done.

What I've tried so far(Might have missed to mention some stuff),
-Updating windows and all drivers
-Disabling SysMain, Search, Update, BITS services.
-Disabling SuperFetch from registry
-Checked for Malware with Malwarebyte
-Disabling AV(I only use Defender)
-Disabling Windows Notifications
-Checked Disk for Bad Sectors (SMART says Good)
-Ran DISM to check and restore System files
-Reset virtual memory
-Using high performance power plan (This works sometimes when switching to this when I get the issue in Balanced power mode, but starts again randomly)
-Ran Disk Cleanup/CCleaner/Defrag
-Clean boot with all Non-Microsoft services and startup services disabled(Still happens in clean boot environment)
-Uninstalled Photoshop CC (Saw somewhere that this cause the issue too) and other unwanted programs.

Other fixes that doesnt apply to me(I hope),
-Chrome and Skype settings(Doesn't use or have installed either of them )
-AHCI Driver tweak in registry (I don't have the mentioned driver file, still did it to the one I have)

Didn't tried,
-Windows Reset, Restore(No restore points anyway) or Reinstall. Like I said before I dont want to do this unless there's no other way.

Other Observations,
-Didn't encounter the issue in Safe Boot mode.

My System : http://speccy.piriform.com/results/XubI2VWlPwl3zZpRlol3oXg

Help me to isolate what is causing the problem rather than saying stuff like "Put to High Performance power plan". I don't want to use High performance mode, I just need to remove whatever is causing the issue and use the computer how I used to.

Thanks!
 
Reactions: Joel_FixerUpper

Dulshan

Reputable
Jun 12, 2015
21
1
4,510
1
I fixed these Warnings and Errors displayed in the Event Viewer and the High Disk usage happens far less often and even when it does its for few seconds.

Event 510 WebCache fix : https://www.tenforums.com/general-support/37841-disable-webcachev01-dat.html
Event 455 TileDataLayer fix : https://www.tenforums.com/performance-maintenance/133197-event-id-455-since-upgrading-v1903-18362-116-a.html

I'll continue to monitor and post back with any other things need fixing. Hopefully this will help others facing the same pain in the a*s issue.
 

Ralston18

Titan
Moderator
How many programs are being launched via Task Manager > Startup?

Stop any programs that you are able to recognize. Idea being to reduce the number of running applications.

Next if the disk usage has dropped then start opening those programs one by one.

Watch disk usage to determine when it goes up again.

Wait a few minutes - just in case there is some other factor involved. Reason being that the program may not immediately try to update, phone home, or do some backup.

Hopefully the last opened/started program will be the culprit.
 

Dulshan

Reputable
Jun 12, 2015
21
1
4,510
1
How many programs are being launched via Task Manager > Startup?

Stop any programs that you are able to recognize. Idea being to reduce the number of running applications.

Next if the disk usage has dropped then start opening those programs one by one.

Watch disk usage to determine when it goes up again.

Wait a few minutes - just in case there is some other factor involved. Reason being that the program may not immediately try to update, phone home, or do some backup.

Hopefully the last opened/started program will be the culprit.
Hello, There are about 5 enabled startup programs. Like I mentioned before I've already tried this with Clean boot disabling all services and startup programs. But the issue still persists. Only in Safe boot I didn't encounter the issue. I tried this in Safe boot mode but it doesn't allow services to be turned on in Safe boot mode.
 
So I'm getting this Disk Usage 100% since about a month for about 5 - 10 mins after bootup and randomly.
You could just save yourself some headache and get SSD for your laptop.

If you want to diagnose the issue and find, what's causing 100% disk usage, then use Resource Monitor.
Open Disk tab, Disk Activity section, order it by column Total, adjust file name column (usually it's too short to be readable) and
post screenshot.

It would look similar to this:
 

Dulshan

Reputable
Jun 12, 2015
21
1
4,510
1
If you want to diagnose the issue and find, what's causing 100% disk usage, then use Resource Monitor.
Open Disk tab, Disk Activity section, order it by column Total, adjust file name column (usually it's too short to be readable) and
post screenshot.
Already tried, Like I said, no process is using the Disk ( No read/writes) just the Active time is at 100%.
 

Ralston18

Titan
Moderator
In Resource Monitor > Disk Activity click the column headers to sort the various columns.

PID 1200 seems to be at the root of things. I.e., MsMpEng.exe

FYI:

https://www.tenforums.com/performance-maintenance/132682-what-does-msmpeng-exe-actually-do.html

And there were some recent (last two weeks or so) problems with Windows Defender. I do believe that MS got that fixed very quickly. Has your system received any recent updates?

Post accordingly.

And there may be other comments and suggestions. I have no problem with that.
 

Dulshan

Reputable
Jun 12, 2015
21
1
4,510
1
Ok so, I used the Performance Analyzer tool is the Windows SDK. Everytime disk usage hits 100% the process called "TiWorker.exe" seemed to be around the top. So I followed some steps to fix Disk Usage issues caused by TiWorker.exe on the net https://www.drivereasy.com/knowledge/fix-tiworker-exe-high-disk-usage-on-windows-10/ Removing the "Software Distribution" folder seems to fix the Hish disk usage just after boot, but still occurs randomly.

Performance Analyzer recording (This was recorded after applying the fix for TiWorker so its nowhere to be seen, I think): https://drive.google.com/open?id=1oaudZfgFA0EANqukDEvDnJuqef70MLIM
 
TI worker is used anytime updates are made and if you disable it you’re gonna have a lot of problems your problems because windows is constantly trying to update

A clean windows installed will probably fix this
 

Dulshan

Reputable
Jun 12, 2015
21
1
4,510
1
Try to disable sound enhancement feature for windows 10 and then i'm guessing the problem will be resolved.
Did, still no luck.

TI worker is used anytime updates are made and if you disable it you’re gonna have a lot of problems your problems because windows is constantly trying to update
I did not disable it, just cleared up the old files.


Also I found these logs in the Event viewer, and there are some bunch of them.


Here's a list of recent events : https://drive.google.com/open?id=1aBxhkR_LQg4lwqjv1AW0Kp9gLfWji92E
 

Dulshan

Reputable
Jun 12, 2015
21
1
4,510
1
I fixed these Warnings and Errors displayed in the Event Viewer and the High Disk usage happens far less often and even when it does its for few seconds.

Event 510 WebCache fix : https://www.tenforums.com/general-support/37841-disable-webcachev01-dat.html
Event 455 TileDataLayer fix : https://www.tenforums.com/performance-maintenance/133197-event-id-455-since-upgrading-v1903-18362-116-a.html

I'll continue to monitor and post back with any other things need fixing. Hopefully this will help others facing the same pain in the a*s issue.
 
Oct 4, 2019
1
0
10
0
Hey, I had the same problem. Here's what helped me:
Right-click on start button>Settings>Privacy>Background Apps> Turn off"let apps run in the background".
Also
Right-click on start button>Settings>Privacy>App Diagnostics>Turn off.

There are a bunch of other settings for camera and mic which you can also turn off.

Hope this helps.
 

ASK THE COMMUNITY