Question Windows 10 - Welcome takes ages to load

VermilionNeko

Distinguished
Apr 24, 2014
195
0
18,680
0
Hi

I'm not sure if this is due to a Windows update, but was wondering if anyone else is experiencing this, or could help pin-point what could be causing the issue. I'm currently on Windows 10 Home, version 20H2. My PC was reformatted not too long ago, so I don't want to be doing that again. But I've noticed my PC takes too long at getting past the Welcome screen. I currently have 24GB RAM and I'm running Windows on an SSD, so this definitely shouldn't be happening. I've been timing it after various things, and there hasn't been much improvement. I've disabled every startup program, but after that, it can still take around 2:20 to load up the desktop. It's never taken that long before. Even my laptop loads up much quicker! It's a bit quicker if I try Safe Boot, but that can still take around 57 seconds. I've tried Selective Startup, so System utilities are mostly disabled, and that can take around 1:15. I've tried a few things I've read, such as disabling Fast Startup. No change. And I've specified how much Virtual Memory the system should use. No change. Plus, my computer crashed and complained it ran out of virtual memory. :unsure: I've even tried resetting my BIOS to default settings. No change. Only thing I can think of trying now, is to completely remove my GPU drivers and install the latest, but I'm not convinced that will help. I'll report back if it does or not.

Thanks
 

VermilionNeko

Distinguished
Apr 24, 2014
195
0
18,680
0
No change with the new GPU drivers.

The SSD with Windows on is fairly new. I bought it as I was running out of space before and there's packs of space. It's a 1TB drive, and I have 762GB left. CPU temps, I believe, are perfectly fine. As I say, I did reset my BIOS settings to default, so it was no longer overclocked. Now that I've overclocked it again, the idle temp is sitting around 32-50 degrees. It's a Haswell CPU as well - the i7 4790K.
 

g-unit1111

Titan
Moderator
No change with the new GPU drivers.

The SSD with Windows on is fairly new. I bought it as I was running out of space before and there's packs of space. It's a 1TB drive, and I have 762GB left. CPU temps, I believe, are perfectly fine. As I say, I did reset my BIOS settings to default, so it was no longer overclocked. Now that I've overclocked it again, the idle temp is sitting around 32-50 degrees. It's a Haswell CPU as well - the i7 4790K.
I did run into this very issue on one of my systems and I think it might be related to the primary boot drive. Because I applied all the BIOS updates and system updates and those didn't really help much. I've also installed and reinstalled Windows 10, and that didn't help much either.

What is the make and model of your primary boot drive?
 

VermilionNeko

Distinguished
Apr 24, 2014
195
0
18,680
0
I did run into this very issue on one of my systems and I think it might be related to the primary boot drive. Because I applied all the BIOS updates and system updates and those didn't really help much. I've also installed and reinstalled Windows 10, and that didn't help much either.

What is the make and model of your primary boot drive?
It was this one, I believe:

https://www.amazon.co.uk/Samsung-MZ-76E1T0B-EU-Solid-State/dp/B078WST5RK/ref=sr_1_4?crid=1JZNFXN66X888&dchild=1&keywords=1tb+ssd+samsung+evo+850&qid=1624388555&sprefix=1tb+ssd+sams,aps,186&sr=8-4
 

g-unit1111

Titan
Moderator
That's a good drive (I have that same one but I don't use it for boot) and I can't understand why it would be that slow to boot. The only thing I could recommend at this point would be either updating your SSD's firmware or updating the SATA controller drivers. That might fix it.
 

VermilionNeko

Distinguished
Apr 24, 2014
195
0
18,680
0
That's a good drive (I have that same one but I don't use it for boot) and I can't understand why it would be that slow to boot. The only thing I could recommend at this point would be either updating your SSD's firmware or updating the SATA controller drivers. That might fix it.
Okay. Thanks for the suggestion. I'll have to look into that next. I've also downloaded the SeaTools SSD utility, and that confirms the drive is 'good' with a 100% life time. The basic test completed fine as well.
 

VermilionNeko

Distinguished
Apr 24, 2014
195
0
18,680
0
still using this motherboard?
Asrock Z97 Extreme 4

it have 6 sata port from chipset and 2 from ASMedia

is the ssd connected to the chipset sata port?
That's the one.. It's kinda old now. To be honest, I'm not actually sure what ASMedia is. But I'm pretty sure all the SATA connectors have been used up now. It was a bit of tight squeeze curving the connector around into the SSD.
 

VermilionNeko

Distinguished
Apr 24, 2014
195
0
18,680
0
So it appears it's set to AHCI, like I suspected. According to the Device Manager, it's an Intel 9 Series Chipset Family SATA AHCI Controller, and it lists two others that just say Standard SATA AHCI Controller. I've tried uninstalling/disabling them and restarting, but no change. I can't find any newer drivers for it either. The USB Host Controller seems to come up, but it's out of date and doesn't support Windows 10.
 

VermilionNeko

Distinguished
Apr 24, 2014
195
0
18,680
0
Also just tried the Samsung Magician software. That says the firmware for all of them is at the latest. 😩 However. I've just noticed, for some bizarre reason, that it says AHCI Mode is deactivated. :unsure: It is on two of them, but active on one.
 

VermilionNeko

Distinguished
Apr 24, 2014
195
0
18,680
0
Yeah, I'm totally lost with this. That utility is saying it's deactivated for two of the drives, but the BIOS seems to be listing it as enabled...? Very weird. Only thing I can think of, is to unplug each drive, connect one up at a time and see what it's set up as. Bit of ball ache though...
 

VermilionNeko

Distinguished
Apr 24, 2014
195
0
18,680
0
The mystery continues… I’ve disconnected and removed every hard drive. I’ve also made a note of every drive that does and doesn’t have AHCI activated. Some probably shouldn’t anyway. Then, I’ve re-connected my Windows SSD back up, and not only does it still say it’s deactivated, my BIOS doesn’t even list it. It’s listed in the area where you specify what drive should boot first, but under the Advanced\Storage Configuration, it only lists my CD/DVD drives. Under the six SATA connections, it just says Not Detected. :??:
 

VermilionNeko

Distinguished
Apr 24, 2014
195
0
18,680
0
<Mod Edit>. After all that… 😩 Really thought I was getting somewhere then… Turns out, the reason it wasn’t being recognised was due to the type of SATA cables I was using. I had bought a SATA adapter with more ports, as the ones on my mobo were running out. I think I had used them up… It was using one from the adapter and didn’t recognise it. Connected one in from the mobo and it recognises it no problem. :D Hell, even the initial splash screen on start appears and disappears really quickly. It was much faster at accessing the BIOS. It now lists it as activated in the Samsung Magician utility. The irony…? The boot times are still the same. 2:20 on the welcome screen. 😢
 
Last edited by a moderator:

VermilionNeko

Distinguished
Apr 24, 2014
195
0
18,680
0
This is so infuriating! I decided to disconnect every SATA cable, and removed my GPU and sound card to get to them properly, and connected my main HDD/SSD in SATA slot 0. I even reset the BIOS using the jumper on the mobo. I think I must have taken my eyes away from the screen, but I noticed, in the time it took to bring up the welcome screen, it finished loading within seconds and brought me back to the desktop! 😱 I thought: ‘Ahaa! We’re getting somewhere…!’ But no. Rebooted - and it’s back to normal again. Painfully slow welcome screen. 😡🤬😩 Right when I think I’ve cracked it - the rug is pulled from under me again. I’ve even tried disconnecting all USB devices, apart from the mouse and keyboard, but that doesn’t look to have helped either.
 

VermilionNeko

Distinguished
Apr 24, 2014
195
0
18,680
0
Update: The problem has been fixed! :D

It looks like it was caused by a Windows update...? I installed the optional update - KB5003690 - which apprently fixes a number of issues. The welcome screen lasts for around 10 or so seconds and I'm onto the desktop! A huge improvement!
 
Update: The problem has been fixed! :D

It looks like it was caused by a Windows update...? I installed the optional update - KB5003690 - which apprently fixes a number of issues. The welcome screen lasts for around 10 or so seconds and I'm onto the desktop! A huge improvement!
bravo. glad you fixed it.

I never install optional updates unless it addresses a SPECIFIC issue i am actually having
 
Reactions: VermilionNeko

ASK THE COMMUNITY

TRENDING THREADS