Question Won't boot after installing Windows 10

HFC

Honorable
Jul 22, 2014
62
0
10,660
15
I'm upgrading from Windows 10 from Windows 7 and now the computer won't boot.

tl;dr: After second upgrade attempt, computer won't boot, giving first MEMORY MANAGEMENT (mfewfpk.sys) and then CRITICAL_PROCESS_DIED. Seems physically fine. Can I get it into any Windows without wiping everything?

Basic specs:
Dell XPS 8700
Windows 7 Pro --> Windows 10 Pro
6 GB RAM (OEM)
2 HDDs

This is my second attempt to upgrade a Dell XPS 8700 from Windows 7 to Windows 10 using a mounted ISO, no external media. The first time it appeared to have installed fine, working beautifully. Upon reboot, it refused then to load the OS, giving a mfewfpk.sys memory error. Although Windows wouldn't load, it got through BIOS and made it to Automated System Repair. I was able to roll it back to Windows 7, research the problem, and try again.

I did some research and found many recommendations regarding McAfee, which had been pre-installed on the computer and never removed. I removed all components and tried the upgrade again.

This system uses 2 monitors. In both upgrades it switched to the secondary monitor during upgrade, but on the first attempt it defaulted back to the main monitor being the main monitor. On the second attempt it could not detect the main monitor. Hardware connections were fine. My first troubleshooting steps were: Checking cable connections, Checking monitor functionality, Activating Windows, Rebooting computer.

The reboot was unsuccessful, looking essentially like the earlier problem. I went through Advanced Repair and told it to roll back updates. This time it didn't go back to Windows 7, but rebooted to Windows 10, again only on the secondary monitor.

An unlabelled progress bar appeared. It could have been Windows or any other program, since everything was still installed. It progressed steadily for about 20 minutes and completed. I poked around the system but didn't change any other settings and tried rebooting again.

The computer now will not load Windows or even Repair. This is the sequence of events it goes through on boot:
  1. The monitor it detects shows an icon that flickers between Analog and Digital. It appears to decide on Digital.
  2. It flashes the Dell logo, then displays the Dell logo with a progress bar (and gets to the end of the bar without issue). During this is displays the two options of BIOS setup and boot options.
  3. It briefly displays the Windows logo.
  4. BSOD (Windows 10 style)
    Stop code: MEMORY MANAGEMENT
    What failed: mfewfpk.sys
  5. Restart
  6. Digital/Analog flicker (settles on Digital)
  7. Dell logo flash, gets through BIOS without apparent issue.
  8. It gives a black screen with blinking cursor. After several seconds the cursor jumps down a few lines. Then black screen.
  9. It displays the Windows logo with "Preparing Automatic Repair"
  10. Black screen
  11. BSOD:
    Stop code: CRITICAL PROCESS DIED
  12. Reboot
  13. Basically repeats at infinitum
I say "basically" repeats because it has some variation, such as not displaying the F2/F12 options, or only giving the Memory BSOD once and then indefinitely showing the CRITICAL PROCESS DIED BSOD on subsequent auto-reboots. Although it claims to be loading Automatic Repair, it never actually gets that far. I never have options of booting to Safe Mode or anything similar.

My many searches have included combinations of keywords including:
  • mfewmpk.sys
  • critical process died
  • "memory management"
  • windows 10
    • upgrade
    • windows 7
  • won't boot
    • variations meaning the same thing
  • (...probably other stuff...)
Troubleshooting activities have included:
  • checking all cables
  • letting it go through the boot process:
    • for a long time;
    • multiple different times after shutdown
  • looking through BIOS settings
    • (but no changes because everything looked fine)
  • looking at boot options
  • Dell ePSA Pre-boot System Assessment
    • multiple times
    • it passed quick test and extended pass
Troubleshooting activities HAVE NOT YET included:
  • Using external medium for clean install
  • Changing stuff in BIOS
  • Switching to UEFI instead of Legacy
  • Opening up the tower
I am not at all concerned with recovering user files. It's multiply backed up, and besides, I know how to recover files. On the other hand, I really, really enjoy not having to set up a computer from scratch. It's a wonderful thing when a computer just upgrades from 7 to 10 and all of the programs and files and most settings are intact.

Most of my research has pointed me toward creating a USB installation medium, which I will do, but I expect that using it will result in what used to be the norm, namely, a complete wipe of programs and settings (and files). I'd much prefer to avoid that.

Most important question:
Can I fix this without wiping everything?
Please?

Basic question: How do I fix this computer?

Can I somehow get it back to Win 7? Will doing something with Legacy/UEFI make any difference? Any BIOS settings I should change? Will using a bootable installation USB only provide the option of a totally clean install?

Also: Any idea why this happened in the first place?

Thanks.
 

britechguy

Notable
Jul 2, 2019
1,336
207
1,190
44
Your best bet is doing a completely clean reinstall of Windows 10. You have already succeeded in associating a digital license with the machine.

I would try doing this with things "as is" as far as UEFI goes first.

a) Completely Clean Win10 (Re)install Using MCT to Download Win10 ISO File

b) Completely Clean Win10 (Re)install Using MCT to Create a Bootable USB Drive

Do follow the step regarding using diskpart in this case.

I do not think you will fix this without wiping everything or I wouldn't suggest it. If you have not tried doing the following, in order, you could before resorting to the completely clean install, but I'm not sanguine about these working at this juncture:

1. Using SFC (System File Checker) and DISM (Deployment Imaging Servicing and Management) to Repair Windows 8 & 10

2. Doing a Windows 10 Repair Install or Feature Update Using the Windows 10 ISO file
 

HFC

Honorable
Jul 22, 2014
62
0
10,660
15
Thank you, Brian. Per your advice I didn't play with UEFI settings, then resigned myself to a complete wipe and got a bootable USB involved. This actually facilitated rolling back to Win 7 via Repair Feature Update. Now the machine is tentatively running Windows 10, although I told the user not to reboot until I can run more tests on it.

I appreciate the links and insight!
 

FALC0N

Splendid
Its worth noting that some older systems needed a bios update to properly run Windows 10. They symptoms you are describing are very similar. This issue supposedly affected Windows 8 as well. I haven't seen it a whole lot, but I have seen it.
 

britechguy

Notable
Jul 2, 2019
1,336
207
1,190
44
When it comes to computers in general, my philosophy regarding UEFI/BIOS updates has changed entirely compared to "the early days of the PC."

For many years, even for professionals, doing BIOS updates was, if not a "black art," then at least a "charcoal gray" one. It was fairly easy to brick a computer if you were not paying attention at every step of the process.

Contrast that to now, where UEFI/BIOS flashing packages are, from the end user/technician end of things not at all unlike any other software installation, Kick it off, let it do its thing, then restart the system to have the flash complete. They're virtually bulletproof and idiotproof, too.

Also, many UEFI/BIOS updates are in direct response to the patching of vulnerabilities. You don't want to be running any system with an "antique" UEFI/BIOS version. So if you haven't checked your computer manufacturer's support pages, drivers & downloads page, for the most recent UEFI/BIOS update you should. And when you find that you're out of date, download and install the newest one.
 

ASK THE COMMUNITY

TRENDING THREADS