Question Advice needed! Tried waking up my laptop from sleep mode but the laptop won't read the OS installed SSD anymore. So, laptop won't boot up!

Jul 1, 2019
1
0
10
0
Hello to all.

I just had a serious problem in booting up my laptop (Asus ROG G751JT).

I left my laptop on Sleep mode. After a while, I came back and tried to wake it up by hitting random keys on my keyboard as usual. But, it didnt work. (if it did, I would know as my mechanical keyboard and mouse which both have backlit LEDs, would light up)
Now, this sometimes has happened before that the laptop doesnt wake up by hitting the mouse or key presses on the keyboard, but does wake up when hitting the power button.

Thinking this time was the same, I hit the power button. Then finally, the keyboard and mouse light up. But the Asus Republic of Gamers logo animation doesnt come up on the screen at all and the computer takes a good 7 or 10 seconds only to load the BIOS.
I just checked if my OS drive is being read and to my biggest fear, it is not! I have also taken out the SSD from the laptop, connected it to another computer with the necessary cable and it doesn't get read. The other traditional hard disk from my same laptop is read though.

I am no expert but I am really afraid that I might have permanently damaged my OS-installed SSD by trying to wake up the laptop by hitting the power button.

I just might be in a very big trouble as this laptop is my main workhorse for my video editing work so I have got all pending projects at stake!

So, I would really appreciate if anybody could help!

Thanks!
 
Hitting the power button would not have damaged it. It sounds like the SSD failed.

When you plug in the drive into your working computer. Does it show up in Disk Management? Which can be opened from a Run prompt and type diskmgmt.msc
 

ASK THE COMMUNITY

TRENDING THREADS