Question Aorus Master z390 help! PC won’t start

Mar 30, 2020
2
0
10
0
Hey guys... I’ve been having some really odd things happen lately and I seriously don’t know what to do anymore.

So about a week ago my desktop stoped working. I tried to power it on and it just kept going on an endless cycle of briefly powering off and trying to power on again.

all the led turned on, the fans started spinning but that was it. About 30 seconds after turning on it would shut off with a click and start all over again.

I disassembled everything to check the connections and reassembled and it was the same all over again. So I gave up. A few hours later I tried it again and it suddenly worked, I could go into windows and the UEFI and everything was like nothing had happened. Except, when I tried to power it off, windows would close, my monitor wouldn’t get any signal anymore but the LEDs wouldn’t turn off unless I kept pressing the power button.

Still I thought of it as a win, I have no idea why it started working again but it did.
But today it started all over again. I can’t turn it on. It tries for about 30 seconds, then clicks and shuts off for half a second and starts all over again.

My mobo has a led screen for troubleshooting but this doesn’t turn on either, all that I can see is a light indicating troubles with the cpu.

Do you have any idea what could be happening?

Specs:

Aorus Master z390
I9-9900k oc to 4.9 GHz
2x16 Gb DDR4 @3466 MHz Corsair Vengeance RGB Pro
GeForce RTX 2080 ti FTW 3 ultra
2x1 TB Samsung v-nand 970 evo plus NVMe M.2
Corsair H150i Pro AIO + 6 other fans
EVGA Supernova 850 G3 80+ gold

This was not a cheap piece of tech and it had been working perfectly for almost a year until a week ago.
I’ve tried clearing the CMOS, trying with only 1 RAM stick at a time and switching to different slots, not using the GPU, checking everything is properly plugged in....
I’m at my wits end...

Also, I don’t know how relevant this could be, but the first time this happened windows asked me to update and I left the pc downloading the update. When I returned the LEDs were on but no signal was coming off of the PC (just as what happens now).

Any ideas? I really need help...

Ps: sorry about any typos, I’m on my phone as I don’t have a PC anymore...
 

ASK THE COMMUNITY

TRENDING THREADS