Question Asus rog strix z390x-e (new build) issues with boot menu/cannot install Windows 10/OS

Jul 17, 2019
2
0
10
0
I just completed a new build on a gaming PC, and this is my first time putting a PC together.

I have an ASUS Rog Strix z390-e motherboard. I had no issues assembling the pieces, and the PC turned on first try, and the BIOS came up without any issue. Under "Storage Information" in the BIOS, both the 500GB SSD and the 2TB HDD show up, however, neither of these drives appear to be "bootable" or accessible in the boot menu/boot priority menu.

I have purchased a license to use Windows 10 and downloaded the correct stuff from the microsoft website to install windows 10 to another computer from a flash drive. I downloaded the files and stuff from my laptop and put them onto an empty 16gb drive. However, upon plugging the flash drive into my new build, it does not appear in the boot menu, either. (Pressing F8 to enter the boot menu gives me the message "The system cannot find any bootable devices.") If I hit "save and exit", while leaving the flash drive plugged in, the computer freezes upon booting up, and will not reach the BIOS.

I am really stuck. I need to install windows 10 onto this computer, but I can't figure out what is going wrong. Is my flash drive somehow corrupt, and I need to try to redownload the information onto a fresh drive? Did I mess up somewhere in assembly? Or is there some obscure setting I need to change somewhere that I am too inexperienced to know about? Any help would be appreciated.
 

ASK THE COMMUNITY