ATI Drivers in Linux

stealth_blade

Distinguished
Mar 16, 2003
143
0
18,680
0
I run dual monitors in linux (Mandriva 2006) with the latest ATI drivers. With the desktop expanded across both monitors I am unable to change the refresh rate on my monitors.

Instead they default to the max possible, 75hz in this case. I want to push it down to 60hz, since they are LCD panels and squeal at this refresh rate. However I can't, even though in linux it shows them as set at 60hz, the panels themselves report 75hz.

I tired opening a ticket with ATI but they refused to help, instead they sent me some dead links to info about video drivers.

I have experimented with Ati-Config to try and change refresh rates. So far all I've managed to do is screw over my x-server.

I can post my xorg file if it will help. Monitors VX924 & SyncMaster 710n.

So, any help?
 

stealth_blade

Distinguished
Mar 16, 2003
143
0
18,680
0
Any chance you could walk me through what to change in my xorg.conf? I've borked it enough times on my own :? .


[code:1:a623c43d37]# File generated by XFdrake.
# **********************************************************************
# Refer to the XF86Config man page for details about the format of
# this file.
# **********************************************************************

Section "ServerLayout"
Identifier "layout1"
Screen 0 "aticonfig-Screen[0]" 0 0
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
EndSection

Section "Files"

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "dri"
Load "glx"
EndSection

Section "ServerFlags"

#DontZap # disable <Crtl><Alt><BS> (server abort)
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
# allows the server to start up even if the mouse does not work
Option "allowmouseopenfail"
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
Option "XkbOptions" "compose:rwin"
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/mouse"
Option "ZAxisMapping" "6 7"
EndSection

Section "Monitor"

# Monitor preferred modeline (60.0 Hz vsync, 64.0 kHz hsync, ratio 5/4)
Identifier "monitor1"
VendorName "Plug'n Play"
ModelName "VX924"
HorizSync 30.0 - 82.0
VertRefresh 50.0 - 75.0
ModeLine "1280x1024" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
ModeLine "768x576" 50.0 768 832 846 1000 576 590 595 630
ModeLine "768x576" 63.1 768 800 960 1024 576 578 590 616
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[1]"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"
Identifier "device1"
Driver "fbdev"
Option "DPMS"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]"
Driver "fglrx"
Option "DesktopSetup" "horizontal"
Option "OverlayOnCRTC2" "1"
BusID "PCI:1:0:0"
EndSection

Section "Device"
Identifier "aticonfig-Device[1]"
Driver "fglrx"
BusID "PCI:1:0:0"
Screen 1
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultDepth 16
SubSection "Display"
Virtual 1280 1024
Depth 8
EndSubSection
SubSection "Display"
Virtual 1280 1024
Depth 15
EndSubSection
SubSection "Display"
Virtual 1280 1024
Depth 16
EndSubSection
SubSection "Display"
Virtual 1280 1024
Depth 24
EndSubSection
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]"
Device "aticonfig-Device[0]"
Monitor "aticonfig-Monitor[0]"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "Screen"
Identifier "aticonfig-Screen[1]"
Device "aticonfig-Device[1]"
Monitor "aticonfig-Monitor[1]"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

[/code:1:a623c43d37]

Thx :D
 

ASK THE COMMUNITY

TRENDING THREADS