[SOLVED] CPU always on max frequency (even when idle)

Aug 3, 2021
7
1
25
1
I noticed a few days ago through ThrottleStop that my CPU (i5 9300h) was always on max frequency (~4Ghz) which is causing some heat issue on idle.
Windows power plan is set to balanced, and Intel SpeedStep seems to be activated. Other than that, the CPU usage usually varies between 5-15% on idle so there doesn't seem to be anything running in the background causing it to actually run at such high frequency.
I also noticed that the System process from windows 10 was sometime using the GPU 1 (RTX 2060) but i don't know why, nor do i know how to stop it.

The laptop i'm using is an Acer V NITRO AN517-51-57TK.
 
Aug 3, 2021
7
1
25
1
I found what was causing the issue, it was the Nvidia Display Container service, I just disabled it (which means i can't access Nvidia Control Panel without manually launching the service.) and the processor now correctly goes back to 1-5% usage at 1.2Ghz when idling.
 
Reactions: uWebb429

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

Speed Shift enabled? Read more here. Can you check and see what OS version you're on at the time of writing? You might want to see if your laptop has any BIOS updates pending(do mention what BIOS version you're on at the time of writing). Don't worry about Plundervolt nerfing hitting you, since you're on ThrottleStop you can circumvent that. On a side note, can you parse what your guide for using ThrottleStop was/is?
 
Aug 3, 2021
7
1
25
1
Welcome to the forums, newcomer!

Speed Shift enabled? Read more here. Can you check and see what OS version you're on at the time of writing? You might want to see if your laptop has any BIOS updates pending(do mention what BIOS version you're on at the time of writing). Don't worry about Plundervolt nerfing hitting you, since you're on ThrottleStop you can circumvent that. On a side note, can you parse what your guide for using ThrottleStop was/is?
Speed Shift is currently disabled, i tried to enable it, but the way it works is pretty weird.

I'm running windows 10 20H2, with build 19042.1110. Just updated the BIOS but that changed nothing (i believe it's bios 1.33 which can be found here https://www.acer.com/ac/en/US/content/support-product/7966?b=1).

I didn't use any guide for throttlestop since i just wanted to undervolt the CPU, it's basically the only thing i changed in there.
 

Jacob 51

Proper
Dec 31, 2020
456
19
185
0
I noticed a few days ago through ThrottleStop that my CPU (i5 9300h) was always on max frequency (~4Ghz) which is causing some heat issue on idle.
Windows power plan is set to balanced, and Intel SpeedStep seems to be activated. Other than that, the CPU usage usually varies between 5-15% on idle so there doesn't seem to be anything running in the background causing it to actually run at such high frequency.
I also noticed that the System process from windows 10 was sometime using the GPU 1 (RTX 2060) but i don't know why, nor do i know how to stop it.

The laptop i'm using is an Acer V NITRO AN517-51-57TK.
That's completely fine. What is the CPU temperature? Use software like HWMonitor to see it.
 
Aug 3, 2021
7
1
25
1
That's completely fine. What is the CPU temperature? Use software like HWMonitor to see it.
It's "fine" as it doesn't impact the performances, but a temperature of about 60-70°C in idle is still pretty annoying, could also reduce the lifespan of the CPU if it stays at max frequency all the time I guess.
 

uWebb429

Prominent
May 22, 2020
243
92
790
28
@AmKazuma - Does ThrottleStop show SST in green on the main screen. That indicates that Speed Shift is enabled. Most computers enable Speed Shift automatically in the BIOS and it cannot be disabled when you are in Windows.

If Speed Shift is enabled, have a look in the FIVR monitoring table to see what Speed Shift EPP value the CPU is using. An EPP value of 0 tells the CPU to use maximum speed regardless of load.

5-15% on idle
Intel CPUs are engineered so they do not slow down if they have a task to perform. That is way too much load for a computer that is supposed to be idle. Check the Task Manager Details tab to see what is running on your computer.

If a computer is using the Windows Balanced power plan and it is idle, it should slow down. Most computers are not really idle.



Also check the C state activity. Idle CPUs have cores that are spending 99% of their time in the low power C7 state. Are you a long ways from that?

 

Jacob 51

Proper
Dec 31, 2020
456
19
185
0
It's "fine" as it doesn't impact the performances, but a temperature of about 60-70°C in idle is still pretty annoying, could also reduce the lifespan of the CPU if it stays at max frequency all the time I guess.
Thats what I wanted to know. That temp on no load is not normal.

Now, to reduce the CPU frequency, you have to change the power plan settings. In the plan settings, look for "Minimum processor state" and out it to 0%. Then it will not run at full speed all the time.

This is not really a problem for every user. My i5 runs at 3.6 GHZ all the time and the temp doesn't cross 55. It stays on 38 in idle.
 
Aug 3, 2021
7
1
25
1
@AmKazuma - Does ThrottleStop show SST in green on the main screen. That indicates that Speed Shift is enabled. Most computers enable Speed Shift automatically in the BIOS and it cannot be disabled when you are in Windows.

If Speed Shift is enabled, have a look in the FIVR monitoring table to see what Speed Shift EPP value the CPU is using. An EPP value of 0 tells the CPU to use maximum speed regardless of load.


Intel CPUs are engineered so they do not slow down if they have a task to perform. That is way too much load for a computer that is supposed to be idle. Check the Task Manager Details tab to see what is running on your computer.

If a computer is using the Windows Balanced power plan and it is idle, it should slow down. Most computers are not really idle.



Also check the C state activity. Idle CPUs have cores that are spending 99% of their time in the low power C7 state. Are you a long ways from that?

SpeedShift indeed seems to be enabled even if not checked in TS. Value is 84. I searched in BIOS but it seems like there is no option to turn it off, is there another way to disable it ?

For the 5-15% CPU usage, it's mostly used by the System process, which is also using "GPU 1 - Copy" for a few seconds every 20 seconds or so.


Also, here's what the C state activity looks like
 

uWebb429

Prominent
May 22, 2020
243
92
790
28
there is no option to turn it off, is there another way to disable it ?
If there is no option in the BIOS to disable Speed Shift then it cannot be disabled.

My computer shows the CPU cores spending an average of 99% of their time in the low power C7 state. When Windows is idle, my cores are idle.

Your C state data shows an average of 75% in the C7 state. That means three quarters of your cores are idle and one of your four cores is not. If a core is always active, the CPU has no reason to slow down.

Speed Shift is not the problem. It is doing what it is supposed to do. It is running your CPU at full speed so it can process the background tasks as efficiently as possible. The problem is your background tasks. My computer does not have System taking up 14.1% of the CPU. Keep an eye on that. You might have a bad driver that is stuck in an endless loop, loading your CPU but not accomplishing anything.

 
Reactions: AmKazuma
Aug 3, 2021
7
1
25
1
If there is no option in the BIOS to disable Speed Shift then it cannot be disabled.

My computer shows the CPU cores spending an average of 99% of their time in the low power C7 state. When Windows is idle, my cores are idle.

Your C state data shows an average of 75% in the C7 state. That means three quarters of your cores are idle and one of your four cores is not. If a core is always active, the CPU has no reason to slow down.

Speed Shift is not the problem. It is doing what it is supposed to do. It is running your CPU at full speed so it can process the background tasks as efficiently as possible. The problem is your background tasks. My computer does not have System taking up 14.1% of the CPU. Keep an eye on that. You might have a bad driver that is stuck in an endless loop, loading your CPU but not accomplishing anything.

Maybe, but how would i know which driver then ?
 
Aug 3, 2021
7
1
25
1
I found what was causing the issue, it was the Nvidia Display Container service, I just disabled it (which means i can't access Nvidia Control Panel without manually launching the service.) and the processor now correctly goes back to 1-5% usage at 1.2Ghz when idling.
 
Reactions: uWebb429

ASK THE COMMUNITY