Question Dead RX470 went back alive after days or hours

Nov 10, 2019
1
0
10
0
Hello everyone, I'm new here.
So these few weeks I've been having a problem with my Powerdevil RX470 4 GB.

My full spec:
Core 2 Quad Q8400
Dell Optiplex 755 motherboard
8 GB of RAM
160GB x 3 HDD
Cooler Master MWE 500

So, previously I've been using GTX 650 and its all fine. After I installed the RX470, the setup went smoothly, just install driver downloaded, no bios settings at all. It all worked well for almost a week, then I started to hear some screeching sound from the fan. At first, I didn't know that it was the GPU so I ignored it. Then a few days after that I noticed the fan doesn't spin anymore even at full load tested with a game, temp is very hot. I'm okay with the fan problem though, then I put two of my 120mm Segotep fan on top of the gpu as the cooler after I removed the original gpu casing and fan. It all worked well again, better temp than the previous fan.

Almost a week later, the GPU suddenly said: "No signal" on my monitor, all sounds are looped. Restarted the pc again can use it for hours like usual for a few days. Then it happened again, and more frequently.

So, after some time giving up thinking it was dead, I even threw it onto the floor, no visible damage seen, then throwed it into the trash. Yesterday, I picked it up again and decided to try again on the same motherboard. Booted up fine and even played Ghost Recon Wildlands for 40 minutes then again no signal. Now, the GPU isn't deteted anymore, means I put my cable through the motherboard there will be an image, but not on the gpu.



TLDR: GPU working, then fan started to scream, the fan stopped, replaced using external fan using Molex, works fine again, a week later no signal, waited for a few hours and can play again for hours without a problem no artefacts anything, repeat can still play. Now, no signal if from gpu but has an image if from MB output.

Edit: Even my old GTX650 says nothing but image can seen if using motherboard cable. GtX 650 fan tries to spin but then stopped. This particular gtx 650 is an Asus that dont need 6 pin. I might suspect its a bad PCIE?
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS