Question Getting Various Graphical and Camera Bugs in Multiple Games

Oct 11, 2020
9
0
20
0
Hi, I've been recently having some issues where certain elements of games flicker in and out of existence, stretch, or are moved up for a few seconds. Here are some videos which allow you to see this issue better:

GTA Online
World of Warcraft 1
World of Warcraft 2
Furmark Test

Some screenshots of the issue

Userbenchmark with all overclocks off

I've tried disabling all of my overclocks, updating my graphics drivers, and changing in-game settings. These issues seem to have came up once I disabled my overclock on my CPU about a day or two ago. I used to clock it at 4.0Ghz, however I disabled it to be 3.7Ghz with 4.3Ghz turbo. I also recently was playing around with my memory overclock, which was changed from 2933Mhz to 3200Mhz on 3000Mhz RAM. However, once I saw these problems I clocked it back to 2933Mhz. I also tried putting everything's clock back to what it was when it was working, and I kept getting the same problems. It seems like the issues have to do with 3D, however I could be wrong. Both games I tested were on different drives. WoW was on the 970 EVO and GTA was on the SP.

Also, about a week ago I started noticing that when I load into World of Warcraft for the first time that day, I get extremely low FPS (around 10-20) for about a minute, until it went back up to around 90 or so. This issue didn't seem to persist for very long though.

Does anybody know what could be causing this?

System specs:
Motherboard: Gigabyte X470 Aorus Ultra Gaming
CPU: AMD Ryzen 7 2700x
GPU: Gigabyte G1 Gaming GTX 1070
RAM: Corsair Vengeance RGB PRO 2x8gb (16gb) DDR4 3000 Mhz C15
PSU: EVGA 750 GQ (750 Watt, 80 Gold, Semi-Modular)
Boot Drive: Samsung 970 EVO 1Tb
Extra Drive: Crucial MX500 1TB Sata SSD / SP 256gb M.2 NVMe
Case: Cooler Master H500
CPU Heatsink: Corsair H115i RGB Platinum
 
Last edited:
Oct 11, 2020
9
0
20
0
Update: After setting my BIOS settings to their Optimized Defaults, I launched WoW to see what would happen. Initially, on one of my characters the little tassels on sword were flipping around, along with some other 3D physics objects that were suppose to interact with gravity and movement within game were spazzing out. When I started recording, it caught me off guard when the entire screen started freaking out, to a much greater extent than before. Usually, certain objects within the game would flicker or move or artifact, but this time is seemed like the entire screen was freaking out. As soon as I stopped recording, the entire-screen artifacts went away. I recorded two videos, one using OBS and one on my phone and uploaded them both. Let me know what you think. Maybe the extra CPU usage triggered it? I tried running the Furmark CPU burner and the Furmark GPU stress test and it seemed like, if anything, I was getting less artifacts than before.

Does anybody have anything they could tell me that would help in the slightest? I'm completely lost here. Should I consider reflowing my GPU? Flashing a new BIOS onto it? Anything would be helpful.

Phone

OBS
 

ASK THE COMMUNITY