Question !HELP! PC NOT BOOTING -NO BIOS

Nov 23, 2019
2
0
10
0
Hi all,
So I built my PC about 1 and a half years ago now and its been fine. I tried turning it on today but it wouldn’t boot at all even tho just Last night i used it. It failed to start and I noticed my RGB mouse didn’t turn on as it always does. The monitor didn’t detect an input. I checked the DP cables but without luck. I noticed when i turned it on the DRAM/DIMM fault LED was on. My immediate response was to open the pc up disconnect power and remove the ram and put it back in. Still the same thing happened when i powered it on. I tried taking one out and leaving one in and even tried putting them in different sockets. No result. I looked online but no article helped me. I resetted the CMOS by taking it out for 5-10 min and then putting it back in. There was no MEM_OK button so can’t recieve any help on that. I made sure all plugs were secure and checked my cpu top ( there shouldn’t be anything wrong with the cpu).

I took my GPU out in the process of removing the CMOS.
after a while I turned on the system but was an idiot and forgot to put the CMOS back in. As a result somehow it went through fine judging from the motherboard lights and was surprised when it checked the DRAM and the LED didn’t stay on. BUT this time the green BOOT_LED was on. This was all done with the CMOS and GPU removed. I also had disconnected it from the monitor so I don’t know whether anything came up on the screen but i doubt it. Okay so i realised my mistake and turned it off immediately but this time it shut down by just one click of the pwr button compared to last time with the dram fault led on i had to hold for 5 secs

I then put the CMOS back in after disconnecting pwr and then powered it back on. For some reason the same BOOT led was one. This next part made me mad with confusion. I then put the GPU back in and screwed everything into place and this time put the my display DP cable into my pc to see if anything popped up on screen. So powered it up again this time everything in place but now it wasn’t the Boot LED problem anymore instead the DRAM led was on and not the Boot Led. This is what i don’t understand. I disconnected the DP wire again and the boot led came on. Then plugged the DP cable into the gpu again this time wasn’t the boot LED but the DRAM led.

pc specs:
Asus rog strix z270e gaming mobo
Corsair vengeance ddr4 ram 3000 mhz
Intel core i7-7700K 4 cores 4.2 ghz
Gpu is evga gtx 1080 ftw
Psu evga supernova 850 g2 (850) watts gold

plzz someone help me with this problem it seems pretty unique and I really need my pc.
 

Sohom

Admirable
try again with one stick of ram and check the ram whether the connectors are dirty or not; also take out the GPU and connect the monitor to intel graphics and see whether it boots or not...
 

ASK THE COMMUNITY