Question I Believe The Power Supply Is Starting To Fail -- Issue Started Overnight

Aug 25, 2022
43
7
35
0
PC was fine yesterday... Went to bed...

This morning attempted to turn the PC on... noticed a 1 second delay between pressing the power button and the machine actually powering on.
It starts and runs fine after that... But this sudden startup delay is worrying me.

Also, usually when I change certain settings in the UEFI, the motherboard will switch itself off for 1 or 2 seconds and restart...
This time, it took some 10 seconds for it restart on its own...

Afraid the PSU might die soon... as in, I turn it off today and it no longer starts tomorrow.


Its a 850W Corsair CS850M wth ~4 years of use...

Note: If I unplug the PSU from the wall, press the power button to discharge its capacitors, and plug it back in... It powers on instantly as usual....
 

Lutfij

Titan
Moderator
Note: If I unplug the PSU from the wall, press the power button to discharge its capacitors, and plug it back in... It powers on instantly as usual....
You might be having a grounding issue though a PSU that's been in service for 4 years will not output the same amount of poweras it did when it was brand new. To add, that green label PSU is what we refer to as a horrible/terrible/badly built PSU.

You should replace it(after borrowing from a friend or neighbor) with a reliably built unit, to power your system and see if the issue persists.

What are the specs to your build? Please list them like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
PSU:
Chassis:
OS:
Monitor:
 
Aug 25, 2022
43
7
35
0
Note: If I unplug the PSU from the wall, press the power button to discharge its capacitors, and plug it back in... It powers on instantly as usual....
You might be having a grounding issue though a PSU that's been in service for 4 years will not output the same amount of poweras it did when it was brand new. To add, that green label PSU is what we refer to as a horrible/terrible/badly built PSU.

You should replace it(after borrowing from a friend or neighbor) with a reliably built unit, to power your system and see if the issue persists.

What are the specs to your build? Please list them like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
PSU:
Chassis:
OS:
Monitor:
Turns out the "ErP Ready" BIOS option was the thing delaying the cold startup. Disabling it fixed the issue.
Also the "Completely Power Off First, Wait A Few Seconds, Restart" behavior when I change certain settings in the BIOS is also gone after disabling "ErP Ready".

My build ->

CPU: Intel Core i5-11400;
Motherboard: MSI B560M-A PRO;
RAM: Crucial 32GB DDR4 2666MHz;
GPUs: AMD Radeon RX 550 640SP + Intel UHD Graphics 730 (for Quick Sync);
PSU: Corsair CS850M 80PLUS Gold 850W;
Chassis: Sharkoon M25-W;
OS: Windows "vNext" Enterprise build 25217.1000.
 
Last edited:
Aug 25, 2022
43
7
35
0
CS850M is a budget Gold PSU and came with only 3 years of warranty for a reason. EOL since the end of 2016/beginning 2017 so with 4 years of use it laid 2 years on the shelf somewhere.
I seriously hope this unit doesn't die soon. Don't have money to get another one right now. Only next month... But then I'll get a very decent high quality PSU for 2023 and beyond.
 

ASK THE COMMUNITY