Question Internet speed slowing through router

Dec 11, 2019
4
0
10
0
I have Comcast 600mbps speed, Netgear Nighthawk X4S R7800 Router and Netgear CM1000 Modem which are all at least using CAT5e ethernet cables. When I direct connect my PC to the modem I get around 700mbps but once I connect it to the router I'm only getting around 110mbps with 15ping. My WiFi speed coming from the router says it's around 500mbps. Why is my speed so slow when I connect my PC directly to my router using wired connection?
 

kanewolf

Titan
Moderator
Factory reset the router and set just the admin password, and the WIFI info. See if that corrects the problem. You could have some option set that is hurting your performance and the easiest way to clear everything is to factory reset.
 
Dec 11, 2019
4
0
10
0
Factory reset the router and set just the admin password, and the WIFI info. See if that corrects the problem. You could have some option set that is hurting your performance and the easiest way to clear everything is to factory reset.
I bought these less then a week ago, they were factory reset and everything.
 
Dec 10, 2019
14
2
15
0
Factory reset the router and set just the admin password, and the WIFI info. See if that corrects the problem. You could have some option set that is hurting your performance and the easiest way to clear everything is to factory reset.
by doing factory reset it will disconnect every device connected to that wifi or it will remain connected?
 
Dec 11, 2019
4
0
10
0
If you changed anything, in that week, then do a factory reset to clear it. Something like QOS or data logging can kill performance. The simplest thing is to do a factory reset.
Tried the factory reset and didn't change anything. My wifi speed is still decent but wired connection is still slower.
 

ASK THE COMMUNITY

TRENDING THREADS