[SOLVED] [Logitech G430] Mic randomly stopped working?

icewolf461

Honorable
Jul 9, 2014
50
0
10,540
3
Hello. I'm in a bit of a pickle as of recently. I got this headset a few weeks ago and it was working fine until this week. Nothing has changed software/hardware wise. No Major windows updates or anything. Only the headset part of it works. The mic doesn't produce any sound at all or sometimes static. I'm stumped at this point on what to do. The mic works fine on laptop, so I've ruled it out as not the headset? But a desktop issue.



Things I've tried:

- Checking Sound Settings in Windows

- Toggling Microphone Access in Privacy settings in Windows

- Turning off mic application exclusivity

- Updating Realtek drivers from Motherboard website

- Updating G430 firmware to 0x0120 (This may have done more harm than good and I'm unsure as how to reverse it. It worked fine on my laptop but now it doesn't work on either desktop or laptop)

- Removing LGS (Logitech Gaming Software and all associated drivers in device manager as per a Logitech CS support suggested then restarting PC and reinstalling LGS then allowing it to install the drivers automatically. This did not work though.

And maybe I tried some other things but can't remember atm lol. Any help is appreciated! Thanks :)
 

joleske1738

Commendable
Sep 10, 2017
35
0
1,540
1
Same thing happend with me. I spent days trying to fix it. Make sure the mic end is plugged in to the mic in port. Honestly, it is worth it just to get a blue snowball for $40. The quality is a whole lot better, and you can still use your headset because it is comfy.
 

joleske1738

Commendable
Sep 10, 2017
35
0
1,540
1
Same thing happend with me. I spent days trying to fix it. Make sure the mic end is plugged in to the mic in port. Honestly, it is worth it just to get a blue snowball for $40. The quality is a whole lot better, and you can still use your headset because it is comfy.
 

ASK THE COMMUNITY

TRENDING THREADS