[SOLVED] My I5 9600k clock speed rapidly goes up and down. Normal?

justxjack

Honorable
Jan 13, 2014
16
2
10,515
0
Just today I built my first gaming PC and am encountering things that I don't know if they are normal or not. This is my first real PC so please forgive me if this is a stupid question.

Anyway, I am monitoring my cpu and noticed that every second or so its clock speed switches between its loweest clock speed, 800mhz, to its highest, 4400mhz. Without noticable difference in load. Note that its base clock speed is 3700mhz and I have NOT overclocked it whatsoever. This is another issue I would like to discuss but I dont want to clutter this board.

What I'm doing during this casual monitoring is:
Running Firefox and downloading a file.
Running the monitoring software, NZXT CAM.
And basic windows stuff like Explorer, taskmanager and settings.

My specs are:
Windows 10 pro
I5 9600k
MSI z390 gaming plus
MSI radeon 5700 xt

Here's a link to a screenshot of NZXT, if you look at the bottom left panrl showing clock speed you can see the intense spikes. Are those normal and is it weird that its reaches 4400mhx while its non-OC'd max clock speed should be 3700mhz?

View: https://imgur.com/a/N6anvyS

EDIT: Changing windows power saving plan to 'high performance' made it so the clock speed stays at 4400mhz. Is this desirable? Will this affect my CPU lifespan?

EDIT: I changed the performance plan back to 'balanced' but the clock speed remains around 4400mhz. Even with the download paused and the CPU at near idle. I went into the bios and there the CPU clock speed was at base. I don't know whats going on.
 
Last edited:

Darkbreeze

Titan
Moderator
Make sure that in the BIOS you have Intel speedstep enabled and that the low power C states are all set to Auto or enabled. If you do not have a power supply that is Intel low power state (Haswell compliant) then do not enable the C6/C7 state. Most modern power supplies ARE compliant, but there are a few models, notable the Seasonic build models (By many brand names) that are 520 or 620w models.

DISABLE Intel speed SHIFT in the BIOS.
 
Reactions: justxjack

Darkbreeze

Titan
Moderator
Yes, it is completely normal for your clock speed to rapidly change going from no load to load sometimes multiple times per second. You do not want to run your CPU at full clock speed at all times. The high performance plan is fine, but if you're going to run it then you want to go into the advanced options for that plan and change the min processor power state to 8% and leave the max setting at 100% so the cores can drop back to low ratios when they are not specifically in use. That will help increase the lifespan of your CPU and will also help to some degree to keep package temperatures somewhat cooler so long as you are not under an all core full load.
 
Reactions: justxjack

justxjack

Honorable
Jan 13, 2014
16
2
10,515
0
Thank you for your reply. While waiting for a response I looked around and well, you are a blessing to this board. I will follow your suggestions.

Have a great day!
 

Darkbreeze

Titan
Moderator
Make sure that in the BIOS you have Intel speedstep enabled and that the low power C states are all set to Auto or enabled. If you do not have a power supply that is Intel low power state (Haswell compliant) then do not enable the C6/C7 state. Most modern power supplies ARE compliant, but there are a few models, notable the Seasonic build models (By many brand names) that are 520 or 620w models.

DISABLE Intel speed SHIFT in the BIOS.
 
Reactions: justxjack

justxjack

Honorable
Jan 13, 2014
16
2
10,515
0
I have a Seasonic Focus Plus Gold 650. I’ve looked online and have not found any information about whether its compliant. Is it fair to assume it is since its not a 520 or 620w model.

I’m running Passmark Memtest 86 at the moment. Once that is complete I will;
Make sure Intel speedstep is enabled,
Make sure the low power C states are set to auto or enabled,
Make sure Intel speed SHIFT is disabled.

I will not touch the C6/C7 state settings until I know it is safe to do so.
 
Last edited:

justxjack

Honorable
Jan 13, 2014
16
2
10,515
0
So, Intel speedstep was already enabled. Intel C-state was also already on auto.

I found a ‘package C state limit’ which had a number of C states including C6, C7 and C7s. I went ahead and put in on C7. I disabled Intel Speed Shift.

I will exit BIOS now and monitor my CPU idle clock speed some more
 

justxjack

Honorable
Jan 13, 2014
16
2
10,515
0
It worked, somewhat. My CPU is back to alternating between ~800mhz and ~4500mhz at near idle load (is perfect idle load even achievable? It seems to - even with nothing running - never go to 0% load but go between 1% and 3%) (It does reach 0% load sometimes with just the taskbar active) which I assume is more desirable than it being at ~4400mhz constantly. It does seem to reach 800mhz a lot less frequently but I''ll "blame" that on high performance mode.

I guess that solves this thread. Thank you very much for your help and advice.
 
Last edited:

Darkbreeze

Titan
Moderator
That is normal. It's not going to "stay" on 800mhz. Windows is constantly running processes, as do other programs. Things are checking for updates. Windows is saving restore points all the time, which is a great way to reduce system resource drainage is by turning OFF System restore. It doesn't ever work right anyhow and you are a LOT better off by using a dedicated third party backup image program like Acronis True image or Macrium reflect to make weekly or shorter frequency backups at your own schedule rather than letting Windows eat resources to create backup images and restore points anytime it wants to.

I always disable System restore on ALL of my machines, and all client machines, and use other backup software than I can disable the automatic features on and only run when I want to.

Anyhow, things are always doing stuff so rarely will you see all cores stay at or near 0% usage for a long time. Something will be doing something every few seconds or so. Totally normal. Looks good to me.

Fact is, every time one of the cores drops to 800mhz and is at low usage, it is getting a chance to rest, versus being at constant 4.5Ghz when it doesn't need to be and staying hot all the time. That's a good thing. The amount of time it takes your cores to go from idle to full usage is a matter of microseconds and you'll never notice the difference.
 

ASK THE COMMUNITY

TRENDING THREADS