Question Need Help with annoying Stuttering Problem

Sep 21, 2022
14
0
10
0
CPU AMD RYZEN 5 2600, Six Core, 3,9GHz 19MB -MB ASROCK AM4 B450 Fatal1ty GAMING K4 4xDDR4 3200Mhz -RAM DDR4 16GB (2x8GB) 3000MHz G.SKILL Ripjaws4 F4-3000C15D-16GRK -PSU 750W 14CM FAN, EVGA GQ, 80+ GOLD -SSD M.2 240GB KINGSTON PCI-E NVMe A1000, SA1000M8 / 240G -VGA MSI Radeon RX 580 ARMOR 8GB, 912-V341-237 -Monitor GIGABYTE 165 Hz
My specs are these.
 
How old is the PSU?

Does it only happen in this game or all games?

Are all your system drivers up to date, includng chipset? The latest chipset drivers will have the most recent Ryzen Balanced Powe which you should use, as it provides best performance for your CPU.

Have you uninstalled/reinstalled latest GPU drivers using DDU (safe mode). If not try that.

Also, what bios are you running at the moment? It might be worth updating to the most recent one, to ensure any bug fixes are helping you, and we can rule out another issue.
 
Sep 21, 2022
14
0
10
0
How old is the PSU?

Does it only happen in this game or all games?

Are all your system drivers up to date, includng chipset? The latest chipset drivers will have the most recent Ryzen Balanced Powe which you should use, as it provides best performance for your CPU.

Have you uninstalled/reinstalled latest GPU drivers using DDU (safe mode). If not try that.

Also, what bios are you running at the moment? It might be worth updating to the most recent one, to ensure any bug fixes are helping you, and we can rule out another issue.
Thanks for the reply dude, the psu is as old as my other hardware parts -3 years. I dont think it is a psu problem. I have the chipset updated to its newest version also for the BIOS what i didnt try is DDU as i read its only used when changing from one graphic card to another which i didnt do.
 
Thanks for the reply dude, the psu is as old as my other hardware parts -3 years. I dont think it is a psu problem. I have the chipset updated to its newest version also for the BIOS what i didnt try is DDU as i read its only used when changing from one graphic card to another which i didnt do.
DDU is always usefull to ensure a clean install and rule that out as a potential problem.

Regarding the PSU, it's possible it can cause freezing, and we can't rule that out just yet.

Did you clear CMOS after bios update? If not, do that first then test again.

What are your CPU/GPU temps like when gaming? Can you run MSI Afterburner and set the OSD to show CPU/GPU power, usage, temps, clockspeed and vram/system ram. Check for any 100% usgage or unusual usage, that you wouldn't expect.
 
Sep 21, 2022
14
0
10
0
DDU is always usefull to ensure a clean install and rule that out as a potential problem.

Regarding the PSU, it's possible it can cause freezing, and we can't rule that out just yet.

Did you clear CMOS after bios update? If not, do that first then test again.

What are your CPU/GPU temps like when gaming? Can you run MSI Afterburner and set the OSD to show CPU/GPU power, usage, temps, clockspeed and vram/system ram. Check for any 100% usgage or unusual usage, that you wouldn't expect.
I will do that and post it.
 
Sep 21, 2022
14
0
10
0
DDU is always usefull to ensure a clean install and rule that out as a potential problem.

Regarding the PSU, it's possible it can cause freezing, and we can't rule that out just yet.

Did you clear CMOS after bios update? If not, do that first then test again.

What are your CPU/GPU temps like when gaming? Can you run MSI Afterburner and set the OSD to show CPU/GPU power, usage, temps, clockspeed and vram/system ram. Check for any 100% usgage or unusual usage, that you wouldn't expect.

Here is the link to the MSI Afterburner screen https://i.postimg.cc/VL9JmMLY/Untitled.png
 
Sep 21, 2022
14
0
10
0
Your GPU seems under used. Have you Ryzen balanced plan running?

When you've done all the things suggested, please confirm so I know what to rule out.
Your GPU seems under used. Have you Ryzen balanced plan running?

When you've done all the things suggested, please confirm so I know what to rule out.
I did the DDU, and again it stutters, the Ryzen Power plan is running and also the GPU is not under used since its going from 0% usage to 99% usage
Here is a pic with 70% usage https://i.postimg.cc/RFs5RBtY/Untitled.png
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS