Question No display issue Help Please

May 7, 2020
20
0
10
0
Hello I bought a new msi a320m-a pro max motherboard it all runs fine fans spin ect but had no display

The other specs are:
AMD 3 3200g
2x4gb 3000mhz sticks
CX 600M PSU
AMD 580 8GB NITRO+
 
Last edited:
May 28, 2020
36
2
45
1
Connect the monitor cable to the GPU pins rather than the MOBO pins as MOBO pins don't connect to monitors unless you have an APU. If you have an Independent GPU then connect the monitor cables to GPU pins.
 
May 7, 2020
20
0
10
0
Connect the monitor cable to the GPU pins rather than the MOBO pins as MOBO pins don't connect to monitors unless you have an APU. If you have an Independent GPU then connect the monitor cables to GPU pins.
I have connected the hdmi cable, ect but I think I found out that, the issue is I need a bios update but I don't know what type of cpu I need to run the bios for the update
 
May 7, 2020
20
0
10
0
Hello I've recently put a build together fans spins power works, but I end up getting no display from the gpu or motherboard. And I'm not really sure what to do.

Specs:
AMD 3 3200G CPU
RX 580 8GB NITRO+ GPU
VENGEANCE LPX 3000MHZ 2X4GB RAM
CX 600M PSU
MSI A320M-A PRO MAX MOTHERBOARD
 
May 30, 2020
8
2
25
1
It likely needs the AMD chipset drivers and a BIOS update wouldn't hurt. This happened to me. I bought a 320 msi board a while ago and got no display out of the box. I had to reinstall my old 750ti ... download and install the newest chipset drivers and then swapped the hdmi cable out to see if I got a signal... it was now working. The box said it was ready to go... clearly it wasn't. Good luck. Hopefully you have an old GPU hanging out for testing purposes...
 
May 7, 2020
20
0
10
0
It likely needs the AMD chipset drivers and a BIOS update wouldn't hurt. This happened to me. I bought a 320 msi board a while ago and got no display out of the box. I had to reinstall my old 750ti ... download and install the newest chipset drivers and then swapped the hdmi cable out to see if I got a signal... it was now working. The box said it was ready to go... clearly it wasn't. Good luck. Hopefully you have an old GPU hanging out for testing purposes...
Annoyingly recently I've just got rid of my old graphics card
 

ASK THE COMMUNITY

TRENDING THREADS