Question Strange stuff. Need help!

Jun 25, 2019
1
0
10
0
Hi all! I'm brand new here so please excuse me if this is in the wrong place or a totally stupid question but I really hope someone can help me here?

I built my PC just before Christmas last year (my first...woop!) and everything's been going great but I have just stumbled into an issue I don't have an answer for and has left me slightly frustrated. You know those times when you don't have a clue what's going on and although it's not stopping you enjoying whatever you're doing you JUST NEED AN ANSWER? Well, that's about it.

Ok (this may take a while but I want you guys to have as much info as possible to help) so I noticed the other day when trying to charge my phone through one of the rear usb ports that I got the old 'power surge on usb port detected' message and something about charging being inconsistent. As if I was rapidly taking the charger out and putting it back in again I guess (it was making the connect and disconnect sounds also). Well, my phones battery has been dying slowly and I know my first thought should have been something along the lines of 'Maybe let's NOT connect this to the computer in the first place' but I'm not hugely tech savvy and decided instead to just unplug it when I saw the alerts pop up. Well, nothing has made me aware of any issues until today when playing MK11 using my Xbox controller through Steam it started making the connect and disconnect noises again. I was using the same usb port and cable to connect my controller that I used to charge my phone. That cable is always in that usb port. My controller didn't once stop working. I guess it was happening quickly but it was enough to make me realise something isn't right. Now, I tried different cables and the same situation happens when it's in that port. Yes, it works absolutely fine in another port and I know most people would just say screw it and leave it at that BUT here's where it got a bit weird. The connect/disconnect sound has completely stopped working when I plug in my controller now to the strange usb port. It works the very first time I connect it after uninstalling and reinstalling the usb Host Controllers (yeah I have tried that already after failing to find any other possible tests and reinstalled drivers for controller etc) but after that there is no sound just a new development that has never happened either. My speakers/headphones (whatever's playing the audio) cut out. It should be playing the 'device connected' audio but...doesn't. If my speakers are on at the same time as my headphones and I plug the controller in through the 'strange port' it switches audio briefly to the speakers for literally a second then comes back to my headphones. It doesn't go from speakers to headphones though it just cuts out from speakers! This has NEVER happened since those 'usb power surge' messages so please forgive me if I seem naive but have I completely screwed that one port? Is there a way I'm unaware of to fix it? It just seems weird that I can still technically play using that port and the controller doesn't shut off when playing but the sound cuts as if it's disconnecting and connecting again and something's obviously gone Pete Tong here and I'm out of ideas. Not that I had many in the first place but it's so randomly frustrating trying to get to the bottom of it.

I should add I guess that I have Mouse and Keyboard plugged into the back (working fine through different ports and funnily enough working fine through the 'strange port' also when attempted)
My speakers are using the audio jack at the back of case (no usb needed for power)
My headphones are plugged in via usb (next to 'strange port')
No update or settings changed aside from uninstalling and reinstalling the usb Host Controllers (although, that seems to have created the new sound errors with headphones passing sound to speakers)
Nothing wrong with controller. Tested on friends PC and no troubles.

I can't really give any more information I'm afraid and what I have given is a jumbled mess. If it's a case of the phone charging has caused an error with that port and in turn that port is causing problems when used I guess I'll have to just use another one but it's bugging me not really knowing. Thank you in advance for any help or advice. Hope you're having a great day/night!
 
Last edited:

Lutfij

Titan
Moderator
Reading your post, I had to smile at the Pete Tong reference. I actually enjoyed watching It's All Gone Pete Tong.

Mind sharing your specs like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
PSU:
Chassis:
OS:

Also include all your components that are plugged into the USB ports. Make sure you're on the latest BIOS update for your motherboard. Then see if reinstalling your chipset drivers helps. Which version of the OS are you on?
 

ASK THE COMMUNITY