Question Alienware Aurora ALX Not Turning On

Aug 2, 2019
2
0
10
0
I haven an alienware aurora alx with an i7 930 24 gbs of ram and i put a gtx1070 in it to test it and it wont turn on only the lights over the motherboard and hard drive cages turn on could it be a motherboard issue?
 

Barty1884

Titan
Moderator
Does it still boot without the 1070? Do you know what GPU was in there originally?

It could be a compatibility issue with the motherboard and, unless you can find reports of it successfully working for others, it's going to be tough to diagnose.

Another potential issue, is the PSU.
That unit could've shipped with a 525W, 875W or 1000W PSU at the time..... but that was ~9 years ago, and I've no idea what the quality was like. If it shipped with the 525W unit, and it was only half decent at the time.... 9 years of aging, and that could be the problem.

.... but I suspect it is a compatibility issue between the other board/BIOS and the GPU.
 
Aug 2, 2019
2
0
10
0
Does it still boot without the 1070? Do you know what GPU was in there originally?

It could be a compatibility issue with the motherboard and, unless you can find reports of it successfully working for others, it's going to be tough to diagnose.

Another potential issue, is the PSU.
That unit could've shipped with a 525W, 875W or 1000W PSU at the time..... but that was ~9 years ago, and I've no idea what the quality was like. If it shipped with the 525W unit, and it was only half decent at the time.... 9 years of aging, and that could be the problem.

.... but I suspect it is a compatibility issue between the other board/BIOS and the GPU.
it still wouldn’t turn on without the gpu and i have the original gpu it shipped with and i tried that an no start it’s the same case lights that turn on
 

ASK THE COMMUNITY