Question ASUS UX330UA No wifi/bluetooth/sound after battery change

Nov 23, 2020
1
0
10
0
Hello everyone,

A couple of days ago I tried (for the first time) to change the battery of my ASUS UX330UA, since the old one was at less than 50% charge.
I used this battery since I couldn't find one made by asus online.

After turning it back on, I noticed that I lost the wifi, bluetooth, and the sound. Oh and one USB port, for whatever reason. The system doesn't find the hardware. After testing different solutions online (I can't really say which one worked since I tried several using Windows which didn't work, and when restarting on Ubuntu, wifi was back (There is a dual boot installed)) , I managed to get back the wifi for a whole evening but after rebooting it, it was lost again.
When I plug in an HDMI cable I do get the sound output on the HDMI. I have not tried an Ethernet cable since I do not have the correct adapter.

Today I installed the old battery again to see if it was somehow related, but the probem continues.

Would you have an idea of what could have caused it? Did I damage something while changing the battery (I don't really think, but you never know)?
I'm open to test all suggestions, wheter on Windows or Ubuntu.

Thanks a lot!
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS