Can't be Pinged from Outside.

TheWhiteRose000

Distinguished
Jul 10, 2010
325
0
18,780
0
Alright, I had a minecraft server up originally on a server I made.
But when it went down I tried running it on my main desktop which used the Killer 2100 NIC.
But for some odd reason any computer running that piece of hardware couldn't create a homegroup or let that computer be pinged outside the network.

I uninstalled it, and removed it now using the onboard NIC but still the same issue remains.
No one can ping my server thru it's IP, not even myself I can only LocalHost it.

Anyone got any advice?
I added exceptions into the firewall for the programs, for inbound and outbound rules and still nothing.
Server IP is 76.4.121.78 seriously try pinging it.
 

TheWhiteRose000

Distinguished
Jul 10, 2010
325
0
18,780
0
Router is fine, old server before it got nuked was running to it and everyone was able to ping it so that just leave's the desktop as the weak link in the chain, every computer I had running the 2100 even after I removed the part couldn't be pinged.

 

Emerald

Titan
Moderator
If I remember it right:

in the Control Panel under Administrative Tools you should see Windows Firewall with Advanced Security

under the Inbound rules should be Echo Request - ICMP. I believe it is the Public setting that need to be set to Allow
 

TheWhiteRose000

Distinguished
Jul 10, 2010
325
0
18,780
0
Did as you said and no Echo Request exists at all, in Inbound rules, heck not even in Outbound, firewall, ect it's like it doesn't exist.

o_0
Also you were dead on in the direction to there, kudo's if you remembered off hand.
 

yimmi

Distinguished
Aug 4, 2011
363
0
18,860
42
I tried pinging it and it freaking works:p
MAC OS here
PING 76.4.121.78 (76.4.121.78): 56 data bytes
64 bytes from 76.4.121.78: icmp_seq=0 ttl=40 time=209.648 ms
64 bytes from 76.4.121.78: icmp_seq=1 ttl=40 time=208.831 ms
64 bytes from 76.4.121.78: icmp_seq=2 ttl=40 time=209.181 ms
64 bytes from 76.4.121.78: icmp_seq=3 ttl=40 time=209.394 ms
64 bytes from 76.4.121.78: icmp_seq=4 ttl=40 time=209.791 ms
64 bytes from 76.4.121.78: icmp_seq=5 ttl=40 time=209.358 ms
64 bytes from 76.4.121.78: icmp_seq=6 ttl=40 time=209.253 ms
64 bytes from 76.4.121.78: icmp_seq=7 ttl=40 time=209.605 ms
64 bytes from 76.4.121.78: icmp_seq=8 ttl=40 time=209.779 ms
64 bytes from 76.4.121.78: icmp_seq=9 ttl=40 time=209.433 ms
64 bytes from 76.4.121.78: icmp_seq=10 ttl=40 time=209.529 ms
^C
--- 76.4.121.78 ping statistics ---
11 packets transmitted, 11 packets received, 0% packet loss
round-trip min/avg/max/stddev = 208.831/209.437/209.791/0.269 ms
 

Hawkeye22

Champion
Moderator
I just pinged it fine too. Are you sure your ISP hasn't assigned that address to someone else. You can check your current address here.

http://www.whatsmyip.org/

Also, I'd double check that ICMP is allowed in your router. I know you said it was working, but can't hurt to double check.
 

Hawkeye22

Champion
Moderator
What program are you trying to use remotely? It may just need port forwarded to the correct PC, otherwise the PC may need set up in a DMZ. Just because you can ping an address doesn't mean the necessary ports are open for access.
 

TheWhiteRose000

Distinguished
Jul 10, 2010
325
0
18,780
0
I'm trying to run my minecraft server, I set everything up previously on a old comp I was using as a home server and it worked just fine, static IP, router ect, but on my desktop no matter which desktop it was it never had that capability I I believe it's cause of the killer 2100 net card I used I removed it and the software but still the problem eludes me, I'm tempted to do a reinstall of the OS to fix the problem.

Something had to have happened software wise during it's install to make a lingering problem now without the hardware or software just locating what the cause is, is driving me crazy.
 

Hawkeye22

Champion
Moderator
The network card shouldn't have anything to do with it. Minecraft servers run on the default port of TCP 25565. You will need to port forward this in your router to the IP address of the minecraft server/PC.

There are plenty of examples on google.

http://www.minecraftforum.net/topic/554-how-to-port-forward-your-minecraft-server-with-pictures/

As an alternative, you could probably enable UPnP on your router, assuming minecraft support UPnP.
 

TheWhiteRose000

Distinguished
Jul 10, 2010
325
0
18,780
0
I've done both, like I said It's not caused from the router, if it was the previous computer I had wouldn't have been able to run the server, I haven't tweaked the settings at all they are exactly the same as they were before, this computer is still hooked into that router also, so the port remains open.
 

Hawkeye22

Champion
Moderator
Well, pinging your address shows that packets are reaching your router, so either your router isn't passing these packets on to the PC or the PC is blocking them. I know you said it worked before and nothing changed, but I would double check your router settings (port forwarding) and also the firewall on the PC the server is being hosted on. Make sure the firewall is allowing TCP on port 25565, assuming you didn't change the default port that minecraft listens on. If these are ok, then I'd try reinstalling minecraft.
 

TheWhiteRose000

Distinguished
Jul 10, 2010
325
0
18,780
0
it's all perfectly fine, hence why I'm saying it's a issue inside the OS, I noted this issue appears whenever I used the killer 2100 in it's build even after removing it the issue still remains, so I'm trying to locate what the killer 2100 actually disabled / tweaked and fix it so the packets get thru.
 

Hawkeye22

Champion
Moderator
Their web site lists this for your killer NIC.

Application Blocking™ - Provides per-application control to block programs that access the network for increased performance and safety.

Maybe you should try using ccleaner and remove any remnants of the killer nic.
 

TheWhiteRose000

Distinguished
Jul 10, 2010
325
0
18,780
0
CMD list's nothing for that port at all, and online it times out saying the port is closed.
But I know the port is open, what could be keeping it closed / non-existent in the system...
 

Hawkeye22

Champion
Moderator
As I stated earlier, only the router and the/any firewall(s) should be in play if you uninstalled the killer NIC.

If the OS is reporting that port 25565 is not listening, then I can only assume minecraft isn't set up correctly. You should see the port listening even if the firewall is blocking it. In this case, the data packet would be dropped by the firewall instead of forwarding it on to the listening application.

I really don't think there is much more I can add to this. If you had a packet sniffer you can watch the flow of traffic on your LAN, but at this point it's probably useless since the port isn't even open and listening.
 

ASK THE COMMUNITY