Dec 23, 2019
2
0
10
0
Hello experts,

I've got a big issue after mounting a fresh new computer and tried to start it: mobo and tower lights and fans are on, but there's no "beep" and no image on screen... I'm completely lost and I don't know where it could come from...

I first thought about a contact failure then I tried to remove the GPU power pins, I tried to remove tower cables from motherboard... but nothing changed.

I read a similar post here : https://forums.tomshardware.com/threads/barebone-built-first-time-booting-no-display-no-beeps.3416562/, but unfortunately it doesn't match my case.

Here's my complete configuration:
  • ASUS TUF Z390M Pro Gaming motheboard
  • 2 x 8gb Corsair Vengeance 3200MHz RAM
  • Geforce RTX 2060 Ventus XS OC 6go
  • Corsair Hydro H100i Pro RGB
  • Intel Core i5 9600K
  • Corsair CX650M 650W
  • Corsair Force MP510 Series 480Go M.2 NVMe PCI Gen 3
To sum up:
  • Computer starts when I'm pushing the tower power button
  • Tower leds are on
  • Motheboard leds are on
  • Corsair proc cooler is running (I can hear it working) and its leds are glowing
  • All fans (proc, GPU) are spinning (even if it doesn't prove anything)
  • No image is displayed on screen
  • No keyboard and mouse leds are lightning. When I'm unplugging and plugging back the mouse, there's a half second where the mouse laser is flashing then nothing...
I'm in big trouble and I hope you experts could help me to solve this!

Have a nice day,
Best regards!
 

ASK THE COMMUNITY