Aug 29, 2023
Hey y'all,

Firstly, my setup:
CPU: AMD Ryzen 5 7600
MOBOs (I tried two - same problem): Gigabyte B650M DS3H and Asrock B650M-HDV/M.2
GPU: Gainward RTX 4070 Ti Phoenix
RAM: G.Skill Ripjaws S5 32GB CL28
Storage: WD Blue SN570 1TB NVMe

I've got some problem with something (nice). My suspicion is that something might be wrong with the software as I tried two motherboards now and the problem persists. The main thing is that with my RTX 4070 Ti Phoenix being seated in the MOBO, it is not detected in BIOS and, obviously, in the Device Manager (if it is kind of detected in the Dev. Mgr. it usually is displaying Code 43 or Code 45). If the system boots up eventually, it always (with some exceptions which are described further) boots through the iGPU and not the RTX 4070 Ti.

Situations when the system boots up with the RTX 4070 Ti only if:
- I eventually manage to boot it up through the iGPU, which is very rare, and then reboot it;
- I reset the CMOS and plug the DP into the RTX 4070 Ti, but when I close off the system it goes back to not booting up or rarely booting up from the iGPU

When the system eventually boots up with the RTX 4070 Ti seated in (but the boot and display goes through the iGPU) it shows some funky stuff in the GPU-Z:


And here is screen from the GPU-Z when I manage to boot up from the iGPU and then reboot the system (the system then boots up normally from the RTX):


Now onto the troubleshooting. Here is the list of things I tried to do to get the system running properly:
- reseat the GPU (and all other componets),
- try different MOBO (now I have Gigabyte B650M DS3H, but the first one I had was the Asrock B650M-HDV/M.2 - same problem BTW),
- I placed the RTX 4070 Ti into my old system with Gigabyte Z370 D3 and Intel i5 8400 and it worked as intended for over two weeks (and still works fine on that system),
- I placed my old GTX 1080 onto the B650 MOBOs and it boots up normally from the GTX,
- reset the CMOS,
- update the BIOS (I also tried older versions on the Asrock and it didn't work out),
- troubleshoot RAM (no problems here),
- update the drivers,
- tried chaning the x16 speed from "Auto" to "Gen3"/"Gen4"/"Gen5" in BIOS,
- set the display priority to "External Graphics" (Asrock MB) and "PCIe 1" (Gigabyte MB),
- ran the PC with the RTX not seated in (the system always boots up properly when the discrete GPU is not seated in).
I think that's the whole list.

Well, the thing is that when I power on the PC with the RTX, everyting lights up (as it should be) except from the keyboard, mouse and mousepad (and the display ofc) - so most of the time I can't even enter the BIOS (nor the system). Also it is interesting that when the system does not boot up at all or it boots through the iGPU (as mentioned - very rare to happen), the fans on the RTX card spin all the time when they shouldn't as there is no load on it. If the system eventually boots up and then I reboot it, the fans on the RTX card spin only when the card is under load.

With the Asrock MOBO there was this curious thing that when booting up with the RTX, the red BOOT light almost everytime lit up (well, as mentioned before, sometimes the system booted up but only through the iGPU). It is not possible to tell with the GB MB cuz it does not have the small debug lights.

After days of trying I'm asking for advice cuz I'm out of ideas. As mentioned before, I don't think the problem is the RTX 4070 Ti as in my older system it boots up normally with no issues whatsoever.

I'm open to any questions, if you've got any - shoot. I'll do my best to provide you with with any screens or other stuff to help you guys/gals. :)

Thanks for any help in advance. <3

PS. Asrock was my first MOBO (I still have it) and Gigabyte is the second one.
Last edited:
Aug 29, 2023
Also here's a photo of a BIOS if I manage to boot up and then reboot the sys. in order to get RTX detected. If I enter the BIOS when the system miraculously boots up from the iGPU (the RTX is not detected most likely), the PCIe x16 is N/A.