Question Gpu not running at full potential

FastbackNL

Reputable
May 27, 2019
108
4
4,595
2
Best reader,

I have recently swaped out my gtx 970 for a 2070 super. It performs (most of the time) really well but I have a problem:
  • On some games like Warthunder and Squad my gpu doesn't use his full potential. It's usage is only around 9% when playing Warthunder, which results in only 60-80 fps.
  • On the other hand, the usage when using Heaven Benchmark 4.0 is around 94-98%.
Why is it that it only performs fully when using the Heaven Benchmark, but not when I am trying to play a game.

The temperatures on my gpu are normal, on the max 70 degrees celcius.

What I have already tried:
  • Changing the energy-plan.
  • Changing different settings ingame, like Vsync etc.
What possibly could be the cause:
- Having a 600 W normal 80+ power supply, even though 650 W is suggested. I can also hear what's called a ''coil whine'' I think.

If you could help me or suggest something, please let me know!

Here are my full system specs:
https://pcpartpicker.com/list/DmqDwc
 

FastbackNL

Reputable
May 27, 2019
108
4
4,595
2
I imagine it could be your PSU but can you run Home - UserBenchmark and post a link to your result,(sometimes it helps to point out a few things.)
Here are my results:
https://www.userbenchmark.com/UserRun/53228105

UserBenchmarks: Game 99%, Desk 92%, Work 96%
CPU: AMD Ryzen 5 3600 - 83.4%
GPU: Nvidia RTX 2070S (Super) - 114.2%
SSD: Samsung 850 Pro 128GB - 105.9%
SSD: Samsung 970 Evo Plus NVMe PCIe M.2 1TB - 330.7%
HDD: Seagate Barracuda 1TB (2016) - 109.2%
RAM: Corsair Vengeance LPX DDR4 3200 C16 2x8GB - 87.1%
MBD: MSI B450 GAMING PLUS MAX (MS-7B86)
 

FastbackNL

Reputable
May 27, 2019
108
4
4,595
2
Thank you all for your answers. I will go ahead and try all of it tomorrow! I will let you guys know if it changes anyting. In the mean time you guys can leave me more suggestions. Thanks anyway.
 

Eximo

Titan
Ambassador
That is about right for a 215W card. assuming a reference model. Based on what we are seeing I would say the GPU is performing to specifications. Your CPU could be holding things back in certain games.

That or War Thunder has settings that are keeping output low. 9% seems silly though. Maybe try a re-install or a graphics re-initialization (ie change a major graphics setting that triggers a game restart)
 

FastbackNL

Reputable
May 27, 2019
108
4
4,595
2
That is about right for a 215W card. assuming a reference model. Based on what we are seeing I would say the GPU is performing to specifications. Your CPU could be holding things back in certain games.

That or War Thunder has settings that are keeping output low. 9% seems silly though. Maybe try a re-install or a graphics re-initialization (ie change a major graphics setting that triggers a game restart)
9% was indeed wrong, Warhunder seems to perform well now, after the game updated. It's running at about 95%. Squad is still running at 70-80%. Could it be my RAM (The sticks in the motherboard)? Because CPU-Z shows that it is running at 1600 mhz, even though the bios says 3200 mhz. I am probably going to upgrade the bios soon. Thank for the help.
 

Eximo

Titan
Ambassador
9% was indeed wrong, Warhunder seems to perform well now, after the game updated. It's running at about 95%. Squad is still running at 70-80%. Could it be my RAM (The sticks in the motherboard)? Because CPU-Z shows that it is running at 1600 mhz, even though the bios says 3200 mhz. I am probably going to upgrade the bios soon. Thank for the help.
Double Date Rate, 1600 is the actual frequency, it is really 3200 MT/s not Mhz, a marketing thing that will plague us for eternity.
 
Reactions: keith12 and kurdtnz

FastbackNL

Reputable
May 27, 2019
108
4
4,595
2
I am also thinking about upgrading my power supply, because I read that my PSU that I am using now (Thermaltake TR2 S 600 W) is not that great. I am thinking about upgrading to the Seasonic Core Gold GC 650, would that be worth it? Thanks again.
 

FastbackNL

Reputable
May 27, 2019
108
4
4,595
2
Changing settings unfortunatly doesn't change the usage much. My rust usage is 40% right now, very weird. Btw, the Psu is very expensive here in the Netherlands unfortunatly. Thanks
 
Apr 13, 2022
26
4
35
0
Here is something intreseting, so I may be completely wrong, but how can it be a psu issue? He said that in heaven benchmark his gpu reaches 95% and assuming it runs it stable, then, the issue can't be from the psu
The fact that the gpu runs at a lower usage in only some scenarios makes it sound like a software issue, maybe the drivers, or the bios, or the game (since he said an update fixed war thunder) or the kind of slow ram, but I may be completely wrong lol. This is just my understanding
 

ASK THE COMMUNITY

TRENDING THREADS