Question Help!!! Last year I built myself a pc for gaming and ever since it’s been issue after issue

Mar 30, 2021
4
0
10
0
Hi
Basically last year I built my first gaming pc and ever since there has been a tonne of issues when playing games.
every time I attempt to play a game it boots me back to my desktop after 5 minutes or reboots my whole computer into the bios.
Specs:
Ryzen 5 2600x
Corsair Vengeance 2x8 gb 3200mhz ram
Gigabyte b450m dsh3 micro tax motherboard
Corsair ssd m.2 (I can’t find original order)
2tb sea gate barracuda hdd
Wraith spire cooler
Msi gtx 1650 super gaming oc
Thermal take 650w RGB non modular psu

I really have no idea watch the issue is some help would be greatly appreciated thanks.
 
Mar 30, 2021
4
0
10
0
test with another psu?
cpu/gpu temp and usage? memory test?
fresh os install after you build the pc? malware scan the system?
Ran a memory test yesterday said there were no issues
Did a clean windows 10 install this morning
And my cpu and gpu are both limited to 98% usage and I have tried playing all my games on the lowest settings thank you for the reply so quickly :)
 

Jacozeelie

Respectable
Mar 1, 2019
652
86
1,970
1
Check your gpu temps, voltage setings and fan curve. Had that exact problem with my gigabyte gtx1650 super 4gb oc. At the end i modified my gpu with a aio 120mm cooler and a fan blowing on vram and vrm's
 

dudio

Honorable
Apr 26, 2015
2,323
21
12,965
470
HWInfo 64 is good for checking temps which might be an issue. I'm also suspicious of the PSU..it could cause what you're seeing. I personally had 2 Thermaltake PSU's prove to be not very good
 
Mar 30, 2021
4
0
10
0
HWInfo 64 is good for checking temps which might be an issue. I'm also suspicious of the PSU..it could cause what you're seeing. I personally had 2 Thermaltake PSU's prove to be not very good
I’ll keep an eye on the temps if that doesn’t work I’ll look into a new PSU
 

ASK THE COMMUNITY