[SOLVED] Help please, Red light for CPU and DRAM on new build ?

Dec 8, 2020
4
0
20
1
I am building a new PC but stuck at power on,

Configuration
AMD Ryzen 5 4650G
ASRock B550M Pro4 MotherBoard
Corsair Vengeance LPX 32GB (2 x 16GB) DDR4 DRAM 3600MHz (CMK32GX4M2D3600C18)
Antec NeoEco 550M 550W

Testing without mounting Motherboard in cabinet, CPU fan runs. No Beep's, No Post, No Display.
Continues RED light for DRAM and CPU, tried to run for about 5 mins no diffrence
Mounted RAM modules few times (A2 and B2, single module in A2 .. no good)

I would appreciate some help. Thanks in advance.
 

helpstar

Polypheme
reset the BIOS by jumper clearCMOS

Is the 8pin EPS/ATX power cable plugged in as well?

Are all pins of the CPU fine and not bent?

How is your monitor connected to the motherboard?

might need a BIOS update to support the RAM

try different RAM or CPU
 

helpstar

Polypheme
reset the BIOS by jumper clearCMOS

Is the 8pin EPS/ATX power cable plugged in as well?

Are all pins of the CPU fine and not bent?

How is your monitor connected to the motherboard?

might need a BIOS update to support the RAM

try different RAM or CPU
 
Dec 8, 2020
4
0
20
1
I don't know what the issue was... but I just dissembled everything, packed it back and had a good sleep.

Put everything back together on next day and whala this time reached bios.. ram was detected at 2133Mhz.. but worked like charm by using XMP profile and Infinity Fabric 1:1 ratio at base 3600mhz
Not doing further OC as of now..

Thanks helpstar for your response.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS