• Find an incredible deal for Black Friday or Cyber Monday? Share those epic bargains with the community by posting them in this forum thread!

[SOLVED] How to block Windows automatically installing/updating integrated graphics?

Orbit Storm

Reputable
Dec 24, 2014
120
0
4,690
3
Currently have an i7-8700K which offers Intel UHD 630 integrated graphics. I also have an NVIDIA GTX 1070 installed as my primary graphics.

I've run into an OpenGL issue with the Intel drivers that prevents me from launching a specific application and I've found that removing the Intel graphics drivers is the only solution. Problem is, I can use DDU to wipe the Intel drivers, reboot, and quickly launch the app without issue but Windows Update kicks in a minute or so after the reboot and automatically installs and updates the IGP.

For the record, disabling the IGP via Device Manager or BIOS doesn't fix the issue so I leave both enabled. I don't use the IGP with my single-monitor setup.

Device Installation Settings is configured to not automatically update. Windows Update service is set to manual and BITS is also set to manual. It seems nothing I do can prevent Windows from seeing this disabled device that doesn't have drivers and automatically bringing it back to life.

How can I prevent this?
 

Orbit Storm

Reputable
Dec 24, 2014
120
0
4,690
3
You'll have to delete drivers manually from Device Manager.
Set variable DEVMGR_SHOW_NONPRESENT_DEVICES to 1.
Check show hidden devices in Device manager and delete drivers for iGPU.
https://www.trishtech.com/2018/04/how-to-view-hidden-devices-in-windows/
You actually gave me an idea that appears to work, although it's not what is quoted. I ran DDU and during the required reboot, entered the BIOS and disabled the IGP. Drivers are gone, IGP is disabled, and the application is working again.

For what it's worth, using Device Manager to uninstall the drivers always had the same result — Windows Update downloading some version and installing it.

Even though it was entirely inadvertent, I appreciate you helping me find a solution that's been three weeks in the making!
 

Orbit Storm

Reputable
Dec 24, 2014
120
0
4,690
3
If you disable integrated graphics in BIOS, then windows would not have reason to update drivers for non-existing hardware.
Disable it in BIOS and uninstall drivers.
If the device is disabled prior to running DDU, then DDU doesn't allow Intel as a selection. It's weird. Suppose DDU can't detect disabled devices to remove the associated drivers.
 

Orbit Storm

Reputable
Dec 24, 2014
120
0
4,690
3
You'll have to delete drivers manually from Device Manager.
Set variable DEVMGR_SHOW_NONPRESENT_DEVICES to 1.
Check show hidden devices in Device manager and delete drivers for iGPU.
https://www.trishtech.com/2018/04/how-to-view-hidden-devices-in-windows/
You actually gave me an idea that appears to work, although it's not what is quoted. I ran DDU and during the required reboot, entered the BIOS and disabled the IGP. Drivers are gone, IGP is disabled, and the application is working again.

For what it's worth, using Device Manager to uninstall the drivers always had the same result — Windows Update downloading some version and installing it.

Even though it was entirely inadvertent, I appreciate you helping me find a solution that's been three weeks in the making!
 

ASK THE COMMUNITY

TRENDING THREADS