Question Installed new graphics card. Splash screen showing up on both monitors

Oct 28, 2018
5
0
10
0
I am helping my cousin with his PC. He had a GTX 1060 that he got from eBay that started to die shortly after he got it so he just got a RX580 to replace it. I tried to delete the NVIDIA drivers for him over Microsoft quick assist because he lives a couple hours away. I did not use DDU initially and ever since then when he turns his PC on, it displays the splash screen on both monitors simultaneously and also when he clicks from one monitor to the other they flash for a second or so. Ive tried to use DDU since then and i completely, or at least made the attempt to, remove both AMD and NVIDIA drivers but the issues still persist.
 
Oct 28, 2018
5
0
10
0
List the FULL PC specs of that computer. Which Motherboard and PSU is he using ? Did he connect all the PCI/PEG connectors to the GPU ? Does he have the latest BIOS installed on his system ??
Ryzen 5 2400g
MSI B450m gaming plus
8gb ddr4 G Skill Aegis 3000mhz
Evga 500w bronze psu
RX 580 8gb
120gb SSD
1TB HDD
Yes he has all the connectors to the graphics card yes he has the latest bios
 

Metal Messiah.

Commendable
Mar 28, 2019
2,147
445
1,790
61
Okay. That's fine. What happens if he uses just a SINGLE monitor, instead of dual ? By SPLASH Screen you mean to say the "Windows Logo", or the motherboard's ? Can he get past the BIOS POST screen, and load his OS ?

I'm not fully sure what might be causing this, but I would also make sure to clear and rest all the CMOS/BIOS settings to default, if need be. Ask him to re-seat the GPU back firmly on the PCI-e slot.
 

ASK THE COMMUNITY

TRENDING THREADS