Question Many games only run when integrated graphics are disabled.

Jun 9, 2021
3
0
10
0
Many games only run when integrated graphics are disabled. If I disable Intel(R) UHD Graphics 620 the game will run normally. Already uninstalled the drivers using DDU - did not help. All drivers are up to date.
Dedicated GPU: NVIDIA GeForce MX 150. I appreciate if anyone can point me to the right direction.
 

matthijsv98

Distinguished
May 14, 2014
41
0
18,540
1
Hey I see you having trouble launching programs on your dedicated GPU. I got some homework for you:

  • First open the Nvidia Control Panel by right-clicking on the desktop.
  • Then navigate to 3D Settings > Manage 3D Settings.
  • Open the tab Program Settings and choose the game from the dropdown menu.
  • Next, select the preferred graphics processor for this program from the second dropdown. Your Nvidia MX 150 should show as High performance Nvidia processor.
  • After that, navigate to 3D Settings > Configue Surround, PhysX.
  • Under PhysX settings set the processor from the dropdown menu to be NVIDIA GeForce MX 150.
This last step is preventing your GPU to crash when you try to launch anything. Also download Geforce Experience to get always the latest driver updates.
 
Jun 9, 2021
3
0
10
0
Hey I see you having trouble launching programs on your dedicated GPU. I got some homework for you:

  • First open the Nvidia Control Panel by right-clicking on the desktop.
  • Then navigate to 3D Settings > Manage 3D Settings.
  • Open the tab Program Settings and choose the game from the dropdown menu.
  • Next, select the preferred graphics processor for this program from the second dropdown. Your Nvidia MX 150 should show as High performance Nvidia processor.
  • After that, navigate to 3D Settings > Configue Surround, PhysX.
  • Under PhysX settings set the processor from the dropdown menu to be NVIDIA GeForce MX 150.
This last step is preventing your GPU to crash when you try to launch anything. Also download Geforce Experience to get always the latest driver updates.
Thank you! But any manipulation with Nvidia Control Panel settings does not help.
 

ASK THE COMMUNITY