• Find an incredible deal for Black Friday or Cyber Monday? Share those epic bargains with the community by posting them in this forum thread!

Question Minimize latency in virtual machine

shmu26

Honorable
Feb 18, 2014
392
0
10,810
20
I am running Linux Mint host, and Windows 10 guest, in VirtualBox.
From my total of 8 gb ram, I allocated 4 gb to the VM. Neither the host nor the guest is maxing out in ram usage, not even close.
And I allocated the VM 2 of the 4 cores.
In the VM, I run light programs such as MS Office and Google Chrome.
Question is how to get latency down to the minimum? Should I customize the VM settings? Run my VM on a different host? Switch to VMWare? None of the above?
 

TheBeerAddict

Reputable
Sep 14, 2015
116
4
4,715
18
Make sure you have virtualization enabled in your BIOS.
Check the VRAM you have allocated for the VM.
You should also monitor CPU, RAM, GPU usage while you experience this lag.
Whats the specs of the drive u hace the VM installed on?
 
Reactions: shmu26

shmu26

Honorable
Feb 18, 2014
392
0
10,810
20
Make sure you have virtualization enabled in your BIOS.
Check the VRAM you have allocated for the VM.
You should also monitor CPU, RAM, GPU usage while you experience this lag.
Whats the specs of the drive u hace the VM installed on?
It's a SATA SSD. I am not experiencing a major lag, it is probably par for the course, but for instance when I type this on the host machine, I can see the difference. I don't see that slight lag. Maybe there is nothing to do, just asking.
Is VMWare less lag?
 

shmu26

Honorable
Feb 18, 2014
392
0
10,810
20
i mean, what you have should work ok, just don't run too many vms or too much stuff on the host. 2 core and 4GB ram is fine. i turn off Accelerated graphics, as I would never game in a vm and my vms are fast and snappy
Does discrete graphics help for proper rendering in unity mode?
 
I am running Linux Mint host, and Windows 10 guest, in VirtualBox.
From my total of 8 gb ram, I allocated 4 gb to the VM. Neither the host nor the guest is maxing out in ram usage, not even close.
I don't know how linux handles this but windows 10 uses more ram the more ram is available to cache things,so just because it's not maxing out it doesn't mean that it has all the ram it needs to run as fast as it can.
And I allocated the VM 2 of the 4 cores.
In the VM, I run light programs such as MS Office and Google Chrome.
You don't need to leave two cores completely empty for linux,especially if you won't run anything on it while you run the VM.
Put all 4 cores to the VM ,it's ok,it's the same thing as any other program using all four cores.


Using an SSD is good but if you have a virtual file it still has to emulate a drive on this file, it's better if you can give the VM full access to an actual partition on the ssd.
 

shmu26

Honorable
Feb 18, 2014
392
0
10,810
20
In VirtualBox, in the Storage tab, I enabled
Use Host I/O Cache
It behaves a little differently, and the typing doesn't have that laggy feeling anymore.
This setting is not enabled by default, because if the guest overwhelms the host cache, it can be a showstopper, but I don't think that is going to happen in my case.
 

ASK THE COMMUNITY

TRENDING THREADS