Question Motherboard powers on then immediately off

Sep 24, 2020
16
0
10
0
I have attached a video of what is happening. But essentially, everything is being powered when i plug in the psu except the motherboard, which flashes for a brief moment. This is a brand new psu and motherboard.
Video
RTX 2060
Ryzen 2700 x
SilverStone 1000W platnum PSU
B450 Aorus pro wifi
 

Schlachtwolf

Commendable
Jun 22, 2019
522
119
1,390
62
First what power supply are you using? A full list of system specs would be helpful.

Did you build it outside the case using an anti-static mat or wristband? If not the static may have zapped your board.... carpet holds loads of static....

Did you remove the battery for 10-15mins to clear CMOS?

Just some food for thought.
 

dimtodim

Respectable
Sep 4, 2018
618
60
1,990
13
Yea i just took it out and the problem seems to keep happening
return mobo
First what power supply are you using? A full list of system specs would be helpful.

Did you build it outside the case using an anti-static mat or wristband? If not the static may have zapped your board.... carpet holds loads of static....

Did you remove the battery for 10-15mins to clear CMOS?

Just some food for thought.
SilverStone 1000W platnum PSU
 
Sep 24, 2020
16
0
10
0
First what power supply are you using? A full list of system specs would be helpful.

Did you build it outside the case using an anti-static mat or wristband? If not the static may have zapped your board.... carpet holds loads of static....

Did you remove the battery for 10-15mins to clear CMOS?

Just some food for thought.
I listed all my specs. I did ground myself, static mats or wristbands really arent too neccessary for the modern day pc components. I will try clearing cmos
 

ASK THE COMMUNITY

TRENDING THREADS