Aug 29, 2019
10
0
10
0
So i use my hyperX cloud 2 control box with my ear buds. Everything used to work, i could hear and the in line mic on the ear buds worked. But now all of a sudden the mic no longer is working. I tested the mic using my phone and it works, so the mic isnt broken, but when i plug it into the hyperx control box, the mic no longer works. Please Help!!!!
 

Lutfij

Titan
Moderator
Open up Device Manager and uninstall the soundcard that's flagged as HyperX

and uninstall it from Device Manager with the option to delete the drivers, after that's done, reboot the system.

As a precursor, can you make sure you're on the latest BIOS update for your motherboard/laptop and that you're on the latest version of Windows 10(assuming you're on Windows 10). We're on version 2004, if you're wondering.
 

Lutfij

Titan
Moderator
Open up Device Manager and uninstall the soundcard that's flagged as HyperX

and uninstall it from Device Manager with the option to delete the drivers, after that's done, reboot the system.

As a precursor, can you make sure you're on the latest BIOS update for your motherboard/laptop and that you're on the latest version of Windows 10(assuming you're on Windows 10). We're on version 2004, if you're wondering.
 
Aug 29, 2019
10
0
10
0
Open up Device Manager and uninstall the soundcard that's flagged as HyperX

and uninstall it from Device Manager with the option to delete the drivers, after that's done, reboot the system.

As a precursor, can you make sure you're on the latest BIOS update for your motherboard/laptop and that you're on the latest version of Windows 10(assuming you're on Windows 10). We're on version 2004, if you're wondering.
Thank you, I got it working again!
 

ASK THE COMMUNITY

TRENDING THREADS