[SOLVED] My new LG34GL750-B 144Hz Gaming monitor is juddering.

JorgeRes

Reputable
Aug 1, 2016
9
0
4,520
1
I used to game on a LG 29' 29UM67-P 60Hz and have a very good experience, always played games at 60 FPS with the in game V-Sync option on, and the gameplay was really smooth.

I bought a new LG34GL750-B 144Hz monitor and i am now using it along with my old one (LG 29' 29UM67-P 60Hz) in a stacked dual monitor display. I want to use my new monitor for gaming and the old one to browse the internet, display pc performance, etc.

The thing is my new monitor is not performing as well as my old one.

I turned the Adaptive Sync On in my monitor settings and the first game i tried was The Witcher 3, almost everything was set to Ultra (V-Sync On) and i was getting 90-110 FPS, and i experience a lot of judder, the gameplay was not smooth at all.
I lowered the settings to minimum (V-Sync On) and even though i was having 144 FPS, there was still some juddering. 144FPS on the 144Hz monitor is feeling worse than 60 FPS on the 60 Hz monitor.
Then i tried lowering the refresh rate of the monitor to various amounts (120,100,75,60 Hz) and the results were the same. Although i saw a slight improvement playing on 75Hz with 75 FPS it was still not as good as playing on 60 Hz with 60 FPS in my old monitor.

I also tried almost every monitor setting, including Adaptive Sync Off, Display Port 1.4 Enabled/Disabled and had no improvement. I tried turning off the V-Sync in the Witcher 3 and also had no improvement.

I tried the NVIDIA Control Panel but the "Set up G-Sync" option is missing. I have the latest GPU drivers installed with GForce Experience and i also have the monitor drivers installed which i got from the LG website: https://www.lg.com/us/support/product/lg-34GL750-B.AUS

My 144Hz monitor is plugged with the DisplayPort cable it came with, and my 60Hz monitor is plugged with an HDMI 2.0 cable.

Outside of gaming everything is fine, my dual monitor setup works perfectly. But like a said previously, when it comes to gaming my new monitor is not performing as well as the old one. I am a bit ignorant when it comes to PCs, but i really dont think this is normal.

Can you guys give me some insight on whats causing this?


--------------------------------------------------------------------------------
SPECS:

DISPLAY 1 (MAIN DISPLAY)): LG34GL750-B 144Hz

DISPLAY 2: LG 29' 29UM67-P 60Hz


MOTHERBOARD: Asus H-97 Pro Gamer 1150 Socket

CPU: Intel Core i7-4790k | 4.00 GHz

CPU COOLER: Cooler Master Hyper 212 EVO

GPU: MSI GeForce® GTX 1080 GAMING X 8GB GD5X

RAM: Corsair Vengeance Pro Series 16GB (2 x 8GB) DDR3 1600MHz

STORAGE: - Samsung SSD 860 EVO 250GB - Seagate 2TB SATA III 64MB

POWER SUPPLY: Corsair Builder Series CXM 600W Modular 80 PLUS Bronze Certified ATX/EPS PSU

OS : Windows 7 Ultimate 64-bit
 

JorgeRes

Reputable
Aug 1, 2016
9
0
4,520
1
I tried a couple of things and everything is working perfectly now. Just for the record, everything i tried was always with the V-Sync on and the FPS always matching the monitor refresh rate.

- First i switched The Witcher 3 from fullscreen to borderless window like Audio31 suggested, this actually made the game a bit smoother but only when running the monitor at 75 HZ. At every other refresh rate there was a lot of judder.
Unfortunately this method only worked with The Witcher 3, every other games i tried (Call of Juarez, Far Cry 4, Metal Gear Ground Zeroes and even MTG Arena) there was judder with fullscreen and borderless screen.

- Then i saw this guy on Youtube tweaking the settings on Nvidia Control Panel:
View: https://www.youtube.com/watch?v=_KsK55zgUAQ

I did basically everything he did and after that every game i mentioned improved drastically, everything started working smoothly just like my old monitor.

- I also received a new DisplayPort Cable today that i ordered before i saw any improvement with the games, the cable is Club3D DisplayPort 1.4 HBR3 8K60Hz. It´s even better now, not only the smoothness is close to perfect but the image quality also improved a bit.


After that i tried various refresh rates (60,75,100,144 Hz) and as long as my FPS match the selected refresh rate i can play games smoothly with no tearing/juddering.
 

Audio31

Commendable
Feb 10, 2017
63
4
1,545
1
Had the same issue with my Samsung, setting the games to borderless instead of full screen seemed to have solved the issue for me.
 

JorgeRes

Reputable
Aug 1, 2016
9
0
4,520
1
I tried a couple of things and everything is working perfectly now. Just for the record, everything i tried was always with the V-Sync on and the FPS always matching the monitor refresh rate.

- First i switched The Witcher 3 from fullscreen to borderless window like Audio31 suggested, this actually made the game a bit smoother but only when running the monitor at 75 HZ. At every other refresh rate there was a lot of judder.
Unfortunately this method only worked with The Witcher 3, every other games i tried (Call of Juarez, Far Cry 4, Metal Gear Ground Zeroes and even MTG Arena) there was judder with fullscreen and borderless screen.

- Then i saw this guy on Youtube tweaking the settings on Nvidia Control Panel:
View: https://www.youtube.com/watch?v=_KsK55zgUAQ

I did basically everything he did and after that every game i mentioned improved drastically, everything started working smoothly just like my old monitor.

- I also received a new DisplayPort Cable today that i ordered before i saw any improvement with the games, the cable is Club3D DisplayPort 1.4 HBR3 8K60Hz. It´s even better now, not only the smoothness is close to perfect but the image quality also improved a bit.


After that i tried various refresh rates (60,75,100,144 Hz) and as long as my FPS match the selected refresh rate i can play games smoothly with no tearing/juddering.
 

ASK THE COMMUNITY