Question New Sata ssd and hdd drive Install caused M.2 "Select proper boot Device" error ?

Rustle Monkey

Distinguished
Oct 8, 2014
4
0
18,510
0
I recently installed a new sata SSD and now my M.2 boot drive will not boot. My system before the new SSD install was a bit special so I'll explain that further.

My System had a M.2 SSD with my current Windows 10 installed on it (Let's call it Drive 0). It also had a second Sata SSD installed (Let's call it Drive 1) that had an old windows installation on it in a Windows.old folder (I believe it also had just a standard windows file still on it as well).

I just installed a Sata SSD and HDD into the 4,5 sata slots on my motherboard. Upon the first boot after the install my system booted into Drive 1. Having done this song and dance before I unplugged all my drive except for Drive 0 and now it boots to a "Select proper boot Device" Error.

At the moment I'm just running on the old windows install on (Drive 1) and (Drive 0) looks totally fine and is fully accessible. Any Ideas on how I can get (Drive 0) booting properly again?
 

Lutfij

Titan
Moderator
Are we dealing with a system or a laptop? If the latter, then parse the make, model and SKU of the laptop. If a prebuilt system, then same story as the laptop. If it's a system built with off the shelf parts, please parse the make and model of your motherboard, the processor paired to the motherboard and the storage drives used.

As a side note, you're advised to format all traces of prior OS installations on other drivers, shut down the system, remove all drives except for the one you intend to install the OS on and then reconnect the previously disconnected drives once you've installed the OS and all relevant drivers.

BIOS version of the motherboard you're working with at the time of writing? Mentioning the slots used by the M.2 SSD would help us two fold. Source of your bootable USB Windows 10 installer?
 

Rustle Monkey

Distinguished
Oct 8, 2014
4
0
18,510
0
This is a system built with off the shelf parts, here is the list of parts request.

Motherboard - X570 Aorus Elite
CPU - Ryzen 3800X
Drive 0 - Western Digital Black SN750 M.2 1Tb
Drive 1 - Kingston SV300 Sata III 240Gb
Bios Info
Bios Version - F11
Bios Date - 12/06/2019
Bios ID - 8AMTS005

The M.2 is currently in the slot labelled M2A on the motherboard (Top Slot), (Second slot is labelled M2B). I also have my windows installation USB on hand.
 

ASK THE COMMUNITY

TRENDING THREADS