• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

Question No beep, no post, no display even after swapping out components

Jul 8, 2020
1
0
10
0
I've been helping my friend with his PC, specs are:

Ryzen 5 2600
Powercolor RX
1x 8GB 2133 DDR4
Gigabyte A320M-S2H
Corsair VS550

He was having visual artifact issues and crashes for a while until one day it just wouldn't boot: no beep, no post, no display.

We have tried replacing the motherboard and PSU with identical components, we tried swapping the CPU for an AMD A8-9600 but still no change.

We've tried swapping all cables, booting with and without RAM, HDD, breadboarding, reseating, etc. Not able to get any change.

The one time we managed to get a beep was when trying to boot with the Ryzen CPU in and no graphics card but this was just to say there was a graphics error and we realised the CPU had no integrated graphics - after reinstalling the GPU there was no beep yet again.

We've got no idea what's going on here, open to all ideas.
 

Gerald6049

Prominent
Jun 9, 2020
599
58
490
22
What is your BIOS version ? If your BIOS is above F40, they no longer support Bristol Ridge (in this case, A8 9600) Due to BIOS ROM size limited . So you can't check the motherboard using A8 9600. At least, using Athlon series.

And I assume the issue is GPU. Have you try another GPU ?
 

ASK THE COMMUNITY

TRENDING THREADS