Apr 20, 2020
First time PC builder here

Built this rig at the start of the year, never once had a problem with it until yesterday.
Motherboard: Asrock X570 Phantom Gaming 4
CPU: AMD Ryzen 5 3600X
GPU: Gigabyte RTX 2060S
RAM: Corsair Vengeance LPX DDR4-3000 (2x 8GB)
PSU: Toughpower GF1 650W Gold

Tried to launch OBS yesterday, it crashed and caused major lag for the next couple of hours, so I tried to restart. PC turned off, but wouldn't turn back on properly. The fans and LEDs all turn on, but there's no display on my monitor.

I checked the monitor and tried a different cable, so I'm confident the problem is with the PC and not the peripherals. I've unplugged and plugged back in all the plugs on the motherboard, and attempted a CMOS reset about 5 times now, none of it having any effect.

I've even removed and re-installed my GPU and RAM sticks in order to make sure they were connected properly, and I have already attempted disconnecting my hard drives in order to boot into BIOS setup.

All of it ends in a "No Signal" display on my monitor.

I don't have any spare parts to swap in and out

Thanks in advance for any advice
Last edited: