Mar 1, 2020
10
0
10
0
hello
I have a n551zu laptop with 2 graphic cards.
I install all the driver and latest Radeon software but I can't use r9m280x card


 
Mar 1, 2020
10
0
10
0
Which BIOS version are you currently working with on your laptop? Which version of Windows 10 are you working with? Also, which version of AMD's drivers are you on at the moment?
os version : win 10 pro build 18363

BIOS Version/Date : N551ZU.307, 1/28/2015

Driver Version : 26.20.15015.1007

Radeon Software Version : 20.1.3

The other problem is that when I plug my laptop into a projector or TV, nothing shows up.
Even when I choose the duplicate mode or other modes.

The laptop does not have a battery and is directly connected to the power supply
 
Last edited:
Mar 1, 2020
10
0
10
0
os version : win 10 pro build 18363

BIOS Version/Date : N551ZU.307, 1/28/2015

Driver Version : 26.20.15015.1007

Radeon Software Version : 20.1.3

The other problem is that when I plug my laptop into a projector or TV, nothing shows up.
Even when I choose the duplicate mode or other modes.

The laptop does not have a battery and is directly connected to the power supply
Can anyone help?
 
Mar 1, 2020
10
0
10
0
Issue:
I have an ASUS N551ZU notebook with switchable graphics, an AMD Radeon R7 integrated GPU, and a Radeon R9 M280X discrete GPU. I have the latest version of Windows 10 as well as AMD software installed on my laptop. Unfortunately, for months I couldn't have my games run on the discrete high-performance R9 graphics, even though I have set the power option to High performance. Clean installation of drivers and Windows, updating BIOS, and installing older versions of drivers have not resolved my problem. Please help, it's really annoying.

Some system specs:
ASUS N551ZU
System: Notebook
OS: Windows 10 Pro v.1909 x64
CPU: AMD FX-7600P 12 Compute Cores 4C+8G
GPUs: AMD Radeon R7 graphics (Integrated DDR3, 1GB) + AMD Radeon R9 M280X (Discrete GDDR5, 4GB)
Driver version: Adrenalin 2020 Edition 20.4.2
Display: 15.6" 16:9 IPS FHD (1920x1080)
Motherboard: ASUSTeK COMPUTER INC. N551ZU
BIOS: N551ZU.307
RAM: 8GB Single-Channel DDR3







 

lga1156_ftw

Prominent
Feb 25, 2020
991
105
640
17
Was your laptop shipped with windows 8.1 or 10? Are you okay using win8.1 if it was shipped with it?
If so just clean install that with usb stick and activate windows if needed, should work fine

Laptop manufactors sometimes dont fix these issues and only way is to use the os shipped with or earliest working version.
 

lga1156_ftw

Prominent
Feb 25, 2020
991
105
640
17
Well i guess you can still try this

  1. disable windows auto updates (everything) only do manual updates
  2. disable amd driver auto updates "adrenalin"
  3. download Adrenalin 20.4.2 manual download put your desktop
  4. download DDU and now boot into safe mode (google how)
  5. Once your in safe mode, plug off all internet cable and wifi
  6. extract and start ddu, select GPU then AMD then press "clean recommended"
  7. let it finish and reboot (still no internet)
  8. while in normal windows install Adrenalin 20.4.2 driver
  9. restart after its done, now plugin internet
  10. keep ALL auto updates off for windows update and adrenalin, checkk and update everything manually nothing amd related
 
Mar 1, 2020
10
0
10
0
Well i guess you can still try this

  1. disable windows auto updates (everything) only do manual updates
  2. disable amd driver auto updates "adrenalin"
  3. download Adrenalin 20.4.2 manual download put your desktop
  4. download DDU and now boot into safe mode (google how)
  5. Once your in safe mode, plug off all internet cable and wifi
  6. extract and start ddu, select GPU then AMD then press "clean recommended"
  7. let it finish and reboot (still no internet)
  8. while in normal windows install Adrenalin 20.4.2 driver
  9. restart after its done, now plugin internet
  10. keep ALL auto updates off for windows update and adrenalin, checkk and update everything manually nothing amd related
I did all these steps, but nothing changed.
 

lga1156_ftw

Prominent
Feb 25, 2020
991
105
640
17
whats the earliest AMD driver (for win10 64bit) you tried to install? Try previous versions (ddu + no internet in between obviously)
You can also try to install windows 8.1 64bit or windows 7 64bit drivers (in compability mode if it doesnt otherwise work) , might not work but you have nothing to lose.
 
Mar 1, 2020
10
0
10
0
whats the earliest AMD driver (for win10 64bit) you tried to install? Try previous versions (ddu + no internet in between obviously)
You can also try to install windows 8.1 64bit or windows 7 64bit drivers (in compability mode if it doesnt otherwise work) , might not work but you have nothing to lose.
I did everything I could but the problem was not solved
I think that with a BIOS update from Asus, the problem will be solved But since 2015, no update has been provided for the BIOS of this model
 

Mani_28

Reputable
Apr 25, 2017
3
0
4,510
0
hey im having the same exact problem with my laptop
ram 8gb
apu amd a8
graphics amd r5 (gpu1) integrated 1gb
amd r5 m230 (gpu2) discreet/switchable with 2gb

do you have any solution for this ?
 
Mar 1, 2020
10
0
10
0
hey im having the same exact problem with my laptop
ram 8gb
apu amd a8
graphics amd r5 (gpu1) integrated 1gb
amd r5 m230 (gpu2) discreet/switchable with 2gb

do you have any solution for this ?
The main problem is that Asus does not update the BIOS.
Some of my friends have solved their problem by installing Windows 8.1, but I'm still looking for a way to fix the problem in new Windows.
 
Mar 1, 2020
10
0
10
0
hello
I struggle for years with my problem and still not a fix for it.
I have a laptop with the dual graphic card but in graphic setting the second graphic card not shown and can't use it.
I do everything you can imagine for solving it like update everything windows, driver cards, and bios even uninstalling with DDU in safe mode and install the latest drivers but nothing happened.
even install different versions of windows with different versions of graphic cards driver
there is no option in bios for the graphic I check it 100 times
I set everything to high performance and still r9 not use in windows10.
my laptop info:
OS Name Microsoft Windows 10 Pro 1909
Version 10.0.18363 Build 18363
System ModelN551ZU
ProcessorAMD FX-7600P Radeon R7, 12 Compute Cores 4C+8G, 2700 Mhz, 4 Core(s), 4 Logical Processor(s)
BIOS Version/DateAmerican Megatrends Inc. N551ZU.307, 1/28/2015
BIOS ModeLegacy
(RAM)8.00 GB





R9 M280x has 4gb memory but windows show 1gb and never use it in the pic everything is 0.



dedicated memory must be 5gb with r9 4gb but it's 1gb just r7 memory recognized.

disable the AMD R7 graphics in the Device Manager The screen goes black and the resolution changes like when no graphics card is installed and use Microsoft basic display adapter.
 

Lutfij

Titan
Moderator
You might want to backup your critical content and see if reinstalling the OS after creating the installer from Microsoft's Media Creation Tool. You should be on 2004 if you do so. Also, install the drivers in an elevated command - i.e right click installer>Run as Administrator after you download the drivers from AMD's support site. Given how old your GPU is, you should be looking at older drivers, not new.
 

ASK THE COMMUNITY