Question "Reboot and select proper boot device" after installing a new SSD ?

dulix11

Distinguished
Sep 5, 2013
75
0
18,640
3
Hello

i have recently installed a new Samsung ssd in my pc and upon booting it back up i am greeted with a "Reboot and select proper boot device" error.

i have a 250gb samsung 970 evo which was the boot drive with windows on it.
Another 1tb 970 evo and the newest ssd is a 2tb qvo.
I had a 2tb hdd installed but it has been unused and right now not connected.

the BIOS says all 3 ssd’s (including the new one) i have are connected and working, i have modified boot orders and priorities. I have changed sata cables and their connection points on the motherboard (sata1, 2, 3…)

boot mode select was set to legacy+uefi when i first opened the bios. If i change it to UEFI the option to select my OS SSD disappears. In fact all of my ssd’s disappear

ive bought Minitool partition wizard but am fairly clueless about what i need it to do for me.

Ive got the software booting from an external ssd, and After using the software to select the 250gb ssd as boot device, i get a BOOTMGR is missing error?

my specs are as follows:
I7 9700k
MSI z390 gaming plus
Gskill 32gb ram
250gb 970 evo
1tb 970 evo
2tb 870 qvo - newly installed

please help!
 
Last edited:
Set BIOS back to legacy+UEFI.
Have only old drives connected (ones you were able to boot into windows previously).
Turn secure boot off,
turn fast boot off,
set sata controller to AHCI.
Restore boot priority settings to previous values.
If you don't remember them, then you'll have to try every option:
Windows Boot Manager - first,​
250GB drive - first,​
1TB drive first.​
After you manage to boot into windows, show screenshot from Disk Management
(upload to imgur.com and post link).
 

dulix11

Distinguished
Sep 5, 2013
75
0
18,640
3
Set BIOS back to legacy+UEFI.
Have only old drives connected (ones you were able to boot into windows previously).
Turn secure boot off,
turn fast boot off,
set sata controller to AHCI.
Restore boot priority settings to previous values.
If you don't remember them, then you'll have to try every option:
Windows Boot Manager - first,​
250GB drive - first,​
1TB drive first.​
After you manage to boot into windows, show screenshot from Disk Management
(upload to imgur.com and post link).
Thanks for the response

i have followed all of these steps and set the boot priorities to defaults, now when i try to boot it up im getting the BOOTMGR is missing?
 
Check Hard Drive BBS settings. 250GB disk should be first in boot order.
Show BBS settings screenshot.

Also - windows is installed in legacy mode.
Remove all UEFI boot options from boot order. Only hard disk boot entry is necessary.
It just makes boot priority list very long and makes boot times longer.

Did you make any changes in minitool software? Change active partition?
It's possible 551MB partition was active before and contains bootloader.
Then such change would have made your system unbootable.
 

dulix11

Distinguished
Sep 5, 2013
75
0
18,640
3
In BBS priorities options - it just reads "Samsung".
Leave only single boot option, remove others.
Make sure it's 250GB drive in Boot option #1.

To set a partition active, you right-click on it and choose "set active".
it is certainly the 250gb that is first priority.

I tried to set the 551mb partition to Active as you described and upon restart it says that an operating system was not detected.

would it be worth reinstalling windows on a different ssd?
 

ASK THE COMMUNITY