Question RTX 2070 WindForce stuck at 300 mhz ?

Jan 17, 2021
1
0
10
0
Tried reinstalling drivers. Used DDU with safe mode and installed older versions. Tried taking out the CMOS battery and waited for BIOS reset. Checked thermal paste in GPU and it seems okay. Was working fine 2 days ago now fps is garbage. 100% gpu utilization but core speed is only 300 mhz. Sometimes spikes to a higher number then just drops to a steady 300 mhz even when under load. Was in the Furmark test and still 300mhz and 39-42 degrees temp. I am losing my mind trying to fix this omg
 

okjak808

Reputable
Feb 23, 2018
186
24
4,615
6
Tried reinstalling drivers. Used DDU with safe mode and installed older versions. Tried taking out the CMOS battery and waited for BIOS reset. Checked thermal paste in GPU and it seems okay. Was working fine 2 days ago now fps is garbage. 100% gpu utilization but core speed is only 300 mhz. Sometimes spikes to a higher number then just drops to a steady 300 mhz even when under load. Was in the Furmark test and still 300mhz and 39-42 degrees temp. I am losing my mind trying to fix this omg
Maybe something related to power saving isn’t letting your GPU rise clocks. You could try go to nvidias control panel, head to manage 3D settings then look for the power management options and set it to maximum performance or adaptive.

Another thing you can do is go to control panel and power options, create your own power option and choose the high power setting.

If none of those work it could be a power delivery issue within your psu, or your GPU is losing its mind and about to die probably but I kind of doubt it since your 2070 should still be new but anything can happen right?

Also if it’s possible list your pc specs.
 

ASK THE COMMUNITY