Question SOLVED: NVMe SSD With OS Not Recognized as a Bootable Device After Clearing CMOS

Apr 15, 2020
4
0
10
1
EDIT: Looks like I am a noob and I posted this in the CPU forum? Idk how that happened but I meant for this to go in either the MoBo or Storage category.

FINAL EDIT:


Ok so this is my only, and final edit to this post. I got no replies but I am editing it now in the event someone has this problem in the future and finds this resource. To be clear, in the end I was unable to get my OS to boot, HOWEVER, I was able to recover all of my data and start fresh with all my old data on a cleanly formatted machine, without any losses; effectively, I found a workaround, not a solution, to my original problem. I will document the steps needed to do this here.

  1. Before anything, read the original post and decide that the problem you face is the same problem I've described here. This procedure WILL wipe your drive, and effectively give you a new OS, though your data will be preserved.
  2. Remove all drives except the misbehaving NVMe drive; this is more or less a protective measure, to prevent any unanticipated data loss.
  3. Create a Windows To-Go USB thumb drive (NOT a Windows installation media). You can use a USB 2.0 if it's all you have around (it's what I used), but it will be quite sluggish.
    • To create a Windows To-Go USB, there are plenty of tutorials floating about online, but I used the Windows Media Creation Tool to download a Windows .iso and used Rufus to create a boot-able USB with Windows To-Go.
  4. Perform your first boot to Windows To-Go on your defunct machine with the NVMe drive inserted. Go through the set up process like normal. You can skip all the online account set up stuff and all the updates; just get to the desktop.
  5. Open File Explorer, and verify that you can see your NVMe drive listed when you select "This PC". If you cannot, you may be out of luck, and your SSD may need to be RMA'd,
  6. Insert an external hard drive onto which you will back up your files. Copy over anything you want to keep (App Data, Documents, or even your whole user folder). Anything you do not save now will be deleted!
  7. Once you're satisfied with you data haul, you will need to create a Windows Installation Media, and again I used the Windows Media Creation Tool.
  8. Insert your installation media into your machine with ONLY your NVMe SSD to prevent erroneous formatting of drives. Verify that you are still unable to boot from your NVMe drive, and that the only boot-able option in BIOS is your installation media.
  9. Install Windows like you normally would for a new machine, selecting custom install, imputing your product key if you have one, and when it asks you for the drive on which you would like to install Windows, you need to delete the partition of your NVMe SSD (there should only be one partition listed), and reformat this drive.
  10. In doing so, you will be able to install Windows cleanly and boot into a fresh, new OS. Don't forget to copy all your files back over from your external storage device. You can also reconnect any additional storage media, such as game drives at this point.
And that's it. Although I was unable to ever learn how to solve my problem, or even why it was happening in the first place, I at least was able to come up with a remedy that preserved all of my data, and only cost me about half a day of downtime.



Thank you for coming to my TED talk.



Initial post follows below.

~ ~ ~ ~ ~



Preface:


Hi all! First time poster, so forgive me if I am missing some of the standard operating procedures here. Please let me know if I am in the right place for assistance. I will attempt to be quite diligent in responding and updating this post.

System Specs:
  • CPU - Ryzen 3900X
  • MoBo - Asus Prime X570 P
  • Memory - G.Skill FlareX 32 GB (2x16 GB) (Part: F4-3200C14D-32GFX)
  • Storage - 500 GB WD Black NVMe Black SSD
  • GPU - GeForce RTX 2080 Ventus 8G OC
  • PSU - EVGA SuperNOVA 750 GA (750 Watt, 80+ Gold)
  • OS - Windows 10 Pro
In Brief:

Today after trying and failing to overclock my memory, I was forced to clear my CMOS when I pushed the envelope a bit too far and I couldn't even enter the BIOS (not sure but it might have failed to POST or, more-likely, the RAM timings were too tight to function). Upon re-inserting the battery and reconnecting everything, I was sent straight back into BIOS and my SSD with my OS was not listed as a boot-able option. Everything else looked normal though. After trying a whole host of possible solutions I feel like I've learned a lot about the issue, yet I'm no closer to solving it.


Description:

Background

I recently built a new system, as my old one (the one from which I write you now) was nigh on 5 years old and it was starting to show. I bought everything fresh and new, save my GPU which was purchased refurbished. I opted for an entry level X570 MoBo as I was not interested in any overclocking at the time of construction. It worked great for the last couple of weeks, I was able to work, game, browse, all at the same time without so much as breaking a sweat. All was well until today, when I, ever the optimist, decided to try and push my luck with some mild memory overclocking. I used Ryzen DRAM calculator to find what I believed to be a safe timing enhancement given my memory specs. To the best of my ability I tweaked around in the BIOS until I was sure everything was input correctly, and I saved and rebooted, only to be greeted with... nothing; I left it for about 5 minutes to think about its life decisions (I thought maybe it needed some time to POST the first time memory settings like this were changed, no idea why). Seeing as nothing was happening, I realized I hecked up and decided to opt for my last-resort option of clearing the CMOS, and this my dear readers is where tragedy struck.


The Problem

After clearing the CMOS, I re-inserted the battery and made sure everything was back in its proper place. I hit the power button and successfully was greeted with the option to enter BIOS, which I did to make sure everything was back to normal. All looked well, my memory was registering as 32 GB and the clock speed and timings were back to the default. Only problem was, I now had no boot-able devices found. I'm getting a little nervous at this point because I was worried I had fried either something on my MoBo or my SSD. Trying not to panic I did all my idiot checks and isolated the problem as best I could. I removed my extra 1 TB drive, and swapped M.2 slots, and still nothing. I verified that the device is registered as an NVMe storage device by the BIOS, and even ran a device self test in the NVMe Configuration page of the BIOS. At this point I decided to do some research and see if other people had this issue. I found a couple of forum posts with some ideas and I tried them but to no avail. I am now stuck with a very expensive paperweight and would like to know if there is anybody out there who can help me out here.


What I've Tried

A post on Tom's Hardware seemed promising, but did not work, despite my best efforts. The description of the problem seemed similar enough that it was worth a shot.

I created a Window's install USB in the event I needed to resort to the nuclear option, but used the install tool to try and view the partition. I found that the installation media was able to recognize the NVMe drive, but it said it wouldn't be able to install windows on that particular partition (I would need to delete/reformat) and gave the following message:

Quote


Windows cannot be installed to this disk. The selected disk has an MBR partition table. on EFI systems, Windows can only be installed to GPT disks.
This is just a little bit beyond the edge of my understanding, despite my best research efforts, so I don't really understand what this means. However, one helpful piece of insight I gained her was that when I selected the Load driver option in the installation screen, and then selected browse, I was able to view my filesystem, including all my documents and folders. and it had the correct "C:" volume label, which did give me a little hope that my data might be recoverable at least.

Next I wanted to see if I could boot to Windows at all on the machine from a separate drive, and if I was going to be able to recover any data from the NVMe drive. So I made a Window's to Go USB and booted to that. And it worked! I was able to view my NVMe filesystem and save the important stuff to another external drive. This verified for me that my filesystem was completely in-tact and the data was recoverable. But despite the OS still being on the drive and functioning more-or-less as any other external drive, I am still unable to get it to boot to windows from the drive.


Conclusion:

And that's pretty much everything the is to tell about how I ended up in this situation, and where I need some assistance. Sorry for the long post, but I wanted to provide any information that could be relevant. To reiterate, I am unable to boot to my NVMe SSD despite all signs pointing to the drive being configured appropriately. This suggests to me that perhaps the issue is somewhere between the BIOS and the drive, but I don't feel like I know enough to say for certain at this time. Any help that some of you might be able to offer would be greatly appreciated.


Also, again, this is my first post so I apologize if some of the minutiae of this forum's etiquette were lost on me, and would appreciate feedback where appropriate.



Thank you.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS