Question Weird display behavior (might be broken?)

vistagamer6969

Prominent
Aug 5, 2019
212
10
615
12
Hello!
So a few days ago I found my first laptop ever (fujitsu amilo li 2727 ms2228) and when I powered it on it showed me a black screen with 2 white vertical lines and a small white spot in the right down corner. I remember some years ago when I powered it on it did the same thing and I haven't used it since then.
Now when I try to connect it with my 1080p monitor through a VGA cable I receive a message on my screen saying "Cannot display this video mode, change input to 1920x1080@60" or something very similar and obviously I can't do that so I decided to swap out the integrated display to see if it helps and it doesn't...
Now I really want to fix this problem but I don't know what component should I change. The display wasn't used too much as far as I can remember.
Should I try changing the display? Could the display cable be faulty (it happened in the past)? Could it be the inverter? Even the motherboard's video chip could be faulty but I really hope it isn't the case...
Monday I was planning to go to a local service to ask for some help too...
 

lga1156_ftw

Prominent
Feb 25, 2020
991
105
640
17
What gpu it has, these series have alot of faulty gpu chips

EDIT: when you move the screen back and forth or try to push from back of screen (where cable is) you get any difference on the picture ?
 

vistagamer6969

Prominent
Aug 5, 2019
212
10
615
12
Man, it's been a long time since I didn't use this machine but as far as I can tell it has a x3100 from intel and T2310 as a processor but I didn't had any problems with the motherboard tho.
when you move the screen back and forth or try to push from back of screen (where cable is) you get any difference on the picture ?
I'll try and come back later
Also thanks for the reply
 

vistagamer6969

Prominent
Aug 5, 2019
212
10
615
12
Well here I am...
I tried connecting again the display to the motherboard and the problem still persists but now the 2 white bars are now black which makes me really think the inverter is dead.
Interesting fact: When I power on the laptop my display is white for 3-4 seconds and then it slowly fades out into black.
I will attach some photos to see what I'm talking about.
View: https://imgur.com/a/VLs9Hki
 

vistagamer6969

Prominent
Aug 5, 2019
212
10
615
12
So... 2 weeks later I'm back.
I bought a second hand inverter from a guy and it doesn't work at all. The screen is completely black, not even a weak light, which is weird because the guy said it tested it and it worked. The codes on them are the same tho.
When I first got it I plugged it in the wrong way, I mean the pink and white were inversely connected on the inverter. Well kind of because it didn't fully connect but by the time I realized the laptop was on. This might have an impact, but when I tried with the old one again it did the thing you can see in photos...
 

ASK THE COMMUNITY

TRENDING THREADS