[SOLVED] Windows 10 Installation Does Not Recognize My NVMe Drive

molonlabe

Distinguished
Aug 4, 2011
10
0
18,510
0
Hey guys,

I have a new build that I'm working on and can't seem to complete the Windows 10 Installation process. My components are listed at the bottom.

The issue that I'm having is that the Windows installation program will not recognize that I have an NVMe drive. The only storage listed is the thumb drive that I'm installing from. The bios does display the NVMe drive and I'm able to customize boot priorities. I've tried disabling fast boot and have set Secure Boot to "other OS" to no avail and have also tried disabling CSM but this actually makes the drive disappear from the bios as well, so maybe there is another setting I am missing.

Components:
OS: Windows 10 via USB thumb drive
Motherboard: Asus Strix X470-i mitx
CPU: AMD Ryzen 5 3600
Hard Drive: 2TB Intel 660p M.2 2280 PCIe 3.0 x4
RAM: 32GB G.Skill Trident Z DDR4 3200
GPU: EVGA GTX 670 SC
PSU: Corsair SF600

Thanks for the help!
 
The NVMe M.2 drive should be the only storage drive connected.

NVMe SSDs do not appear within the BIOS until Windows creates the system partition with the EFI Boot Sector. Your M.2 SSD contains UEFI driver information within the firmware. By disabling the CSM module, Windows will read and utilize the M.2-specific UEFI driver

Go into the BIOS, under the boot tab there is an option for CSM. Make sure it is disabled.

Click on the secure boot option below and make sure it is set to another OS, not windows UEFI.

Click on key management and clear secure boot keys.

Insert a USB memory stick with a bootable UEFI USB drive with Windows 10 Setup* on it, USB3 is quicker but USB2 works too. A Windows DVD won’t work unless you’ve created your own UEFI Bootable DVD.

Press F10 to save, exit and reboot.

Windows 10 will now start installing to your NVME drive as it has its own NVME driver built in.

When the PC reboots hit F2 to go back into the BIOS, you will see under boot priority that windows boot manager now lists your NVME drive.

Click on secure boot again but now set it to Windows UEFI mode.

Click on key management and install default secure boot keys

Press F10 to save and exit, Windows will finish the install. Once you have Windows up and running, shutdown the PC and reconnect your other SATA drives.

*How to create a bootable UEFI USB drive with Windows 10 Setup
https://winaero.com/blog/how-to-create-a-bootable-uefi-usb-drive-with-windows-10-setup/

The Windows 10 ISO link is broken in the above. You can obtain the ISO file here:
https://www.microsoft.com/en-us/software-download/windows10
 
Reactions: molonlabe
If your bios doesn’t recognize it then there’s no way to install your OS on it. I would check the installation and try another slot if you have one. If it doesn’t show up then either the drive or motherboard are bad.
 

molonlabe

Distinguished
Aug 4, 2011
10
0
18,510
0
If your bios doesn’t recognize it then there’s no way to install your OS on it. I would check the installation and try another slot if you have one. If it doesn’t show up then either the drive or motherboard are bad.
Thanks for the reply!
What do you mean by "check the installation?"
Again, the BIOS does recognize the drive when the motherboard is at the default settings. Only when I disable CSM does it disappear.
 
The NVMe M.2 drive should be the only storage drive connected.

NVMe SSDs do not appear within the BIOS until Windows creates the system partition with the EFI Boot Sector. Your M.2 SSD contains UEFI driver information within the firmware. By disabling the CSM module, Windows will read and utilize the M.2-specific UEFI driver

Go into the BIOS, under the boot tab there is an option for CSM. Make sure it is disabled.

Click on the secure boot option below and make sure it is set to another OS, not windows UEFI.

Click on key management and clear secure boot keys.

Insert a USB memory stick with a bootable UEFI USB drive with Windows 10 Setup* on it, USB3 is quicker but USB2 works too. A Windows DVD won’t work unless you’ve created your own UEFI Bootable DVD.

Press F10 to save, exit and reboot.

Windows 10 will now start installing to your NVME drive as it has its own NVME driver built in.

When the PC reboots hit F2 to go back into the BIOS, you will see under boot priority that windows boot manager now lists your NVME drive.

Click on secure boot again but now set it to Windows UEFI mode.

Click on key management and install default secure boot keys

Press F10 to save and exit, Windows will finish the install. Once you have Windows up and running, shutdown the PC and reconnect your other SATA drives.

*How to create a bootable UEFI USB drive with Windows 10 Setup
https://winaero.com/blog/how-to-create-a-bootable-uefi-usb-drive-with-windows-10-setup/

The Windows 10 ISO link is broken in the above. You can obtain the ISO file here:
https://www.microsoft.com/en-us/software-download/windows10
 
Reactions: molonlabe

molonlabe

Distinguished
Aug 4, 2011
10
0
18,510
0
The NVMe M.2 drive should be the only storage drive connected.

NVMe SSDs do not appear within the BIOS until Windows creates the system partition with the EFI Boot Sector. Your M.2 SSD contains UEFI driver information within the firmware. By disabling the CSM module, Windows will read and utilize the M.2-specific UEFI driver

Go into the BIOS, under the boot tab there is an option for CSM. Make sure it is disabled.

Click on the secure boot option below and make sure it is set to another OS, not windows UEFI.

Click on key management and clear secure boot keys.

Insert a USB memory stick with a bootable UEFI USB drive with Windows 10 Setup* on it, USB3 is quicker but USB2 works too. A Windows DVD won’t work unless you’ve created your own UEFI Bootable DVD.

Press F10 to save, exit and reboot.

Windows 10 will now start installing to your NVME drive as it has its own NVME driver built in.

When the PC reboots hit F2 to go back into the BIOS, you will see under boot priority that windows boot manager now lists your NVME drive.

Click on secure boot again but now set it to Windows UEFI mode.

Click on key management and install default secure boot keys

Press F10 to save and exit, Windows will finish the install. Once you have Windows up and running, shutdown the PC and reconnect your other SATA drives.

*How to create a bootable UEFI USB drive with Windows 10 Setup
https://winaero.com/blog/how-to-create-a-bootable-uefi-usb-drive-with-windows-10-setup/

The Windows 10 ISO link is broken in the above. You can obtain the ISO file here:
https://www.microsoft.com/en-us/software-download/windows10
I'm going to try everything listed here and will report back.
 

molonlabe

Distinguished
Aug 4, 2011
10
0
18,510
0
Problem solved! After reinstalling all of the hardware and following the advice provided by Clavin7, I got Windows 10 recognizing my hard drive and the installation process went smoothly from there. Thank you!
 

ASK THE COMMUNITY

TRENDING THREADS