Question ASUS ROG STRIX GS-AX5400 Blocking WOL (by MagicPacket) (?)

danytancou

Distinguished
Dec 9, 2013
54
0
18,540
1
Hi everyone,

I got this router because my previous NETGEAR WDNR-3700 was getting a bit slow for streaming (still works as well as it always did). With the NETGEAR, used to be able to send a Magic Packet from any device on my network (laptops, desktops & tablets all running Win10 using the old (2001) WakeOnLan command-line only utility, or iPhones using the WOL app) to a Win10 box that's my home server to wake it up. This doesn't work with the ASUS router; this router has its own on-board WOL "app", and if I use that, the server wakes up. When I swap back to the NETGEAR router, everything works as it did before, from any and all my devices, without making any changes to network configurations anywhere. (This is probably irrelevant, but just in case: the DHCP server is enabled on both routers, but IPs for all the machines/devices in question are fixed, and the fixed IP tables are identical on the routers. (No, I do not have the two routers powered up at the same time; I simply swapped back to the NETGEAR to see if WOL continues to work like it did before.) I'm not trying to wake the computer up from outside my LAN, i.e., "over the internet", so I don't think this has anything to do with Port Forwarding.)

All this considered, I think the only logical conclusion is that somehow, the ASUS router is blocking WOL MagicPackets (but please let me know if I've missed something obvious). If this is true, can anyone think of a setting that I would need to enable or disable on the router that will allow this to work? (I contacted ASUS support and the experience was a waste of time, as usual with ASUS: the guy asked me what a Magic Packet is, so I hung up without answering. 'Nuff said.)

Thanks in advance.

Dany
 
Last edited:
That is very strange since if you asked how you could block WoL or really any traffic between lan devices I would tell you it can't be done on a consumer router

For traffic that goes lan/lan the traffic basically passes through a switch chip similar to 5 port unmanaged switches. These have no ability to filter traffic. The traffic does not even pass through the CPU chip for performance reasons so the main router function can not see lan/lan traffic. Wifi is bit more complex but in general that traffic is connected to the switch part of the router and not the cpu/router part.

WoL has been messed up a lot by microsoft and all it stupid sleep and low power modes. Most these issues though are on the end device and the bios support.

To test this I would load wire shark on the machine you are trying to wake and capture the wake packets. The sending device does not know that the machine is awake so you should be able to actually see the packets being sent.

Key here is WoL uses only mac addresses. Many apps for some reason use IP and port numbers. Very technically the packet should not have IP headers but most implementation don't seem to care if there is extra junk in the packets as long as it has the magic string. The other thing is the packet is suppose to be send to
the broadcast mac ie FFFF.FFFF.FFFF. Many applications send it to the mac of the end device they are trying to wake. This too mostly work.

The issue I have seen is first mircosoft crap putting the bios in a state that does not take actual WoL packets and the inconsistent implementation of support for WoL packets that do not follow the WoL standard exactly.
 

kanewolf

Titan
Moderator
Hi everyone,

I got this router because my previous NETGEAR WDNR-3700 was getting a bit slow for streaming (still works as well as it always did). With the NETGEAR, used to be able to send a Magic Packet from any device on my network (laptops, desktops & tablets all running Win10 using the old (2001) WakeOnLan command-line only utility, or iPhones using the WOL app) to a Win10 box that's my home server to wake it up. This doesn't work with the ASUS router; this router has its own on-board WOL "app", and if I use that, the server wakes up. When I swap back to the NETGEAR router, everything works as it did before, from any and all my devices, without making any changes to network configurations anywhere. (This is probably irrelevant, but just in case: the DHCP server is enabled on both routers, but IPs for all the machines/devices in question are fixed, and the fixed IP tables are identical on the routers. (No, I do not have the two routers powered up at the same time; I simply swapped back to the NETGEAR to see if WOL continues to work like it did before.) I'm not trying to wake the computer up from outside my LAN, i.e., "over the internet", so I don't think this has anything to do with Port Forwarding.)

All this considered, I think the only logical conclusion is that somehow, the ASUS router is blocking WOL MagicPackets (but please let me know if I've missed something obvious). If this is true, can anyone think of a setting that I would need to enable or disable on the router that will allow this to work? (I contacted ASUS support and the experience was a waste of time, as usual with ASUS: the guy asked me what a Magic Packet is, so I hung up without answering. 'Nuff said.)

Thanks in advance.

Dany
Unless you were to capture the network traffic there is no way to know what the behavior of the old data flow was compared to the new one.
My guess is that the router has some kind of broadcast filtering enabled by default. The iPhone may not work because there could be a WIFI to LAN broadcast block.
All Asus has is a quickstart guide, so I can't help a whole lot.
 
Last edited:

danytancou

Distinguished
Dec 9, 2013
54
0
18,540
1
Thanks guys! WireShark (can't believe I didn't think of using it) showed no wake packets arriving from any devices -- except from the ASUS router itself of course. As a last resort, I did a factory reset and reconfigured the router ("manually", not by loading up the .cfg I had saved) but this didn't help. Not knowing what else to do, I took it back to the store and exchanged it for another unit (same model). I didn't feel like wasting more time going through another manual configuration, so I just loaded up the .cfg I had saved and... now Wake on Magic Packet works perfectly from all my devices, like with the NETGEAR router!!

Not sure what to think, other than that there was (clearly) something wrong with the original unit -- but obviously no idea what... everything else (or at least the stuff I configured/made use of) worked perfectly! This was an oddly specific thing to somehow be broken on a router, but there you have it. (I am no expert with routers, but I think I have a good head on my shoulders when it comes to computer hardware, and none this makes any sense -- especially given @bill001g 's explanation above! I'm glad it's fixed, but I tell ya, if I hadn't experienced this myself, I would not believe such a story!)

Thanks again,

Dany
 

ASK THE COMMUNITY