[SOLVED] Can't boot from newly installed M.2 drive. Windows installed but drive not recognised in BIOS.

Jakobjump

Reputable
May 31, 2014
31
0
4,540
SE
Hi!

I just received an Intel SSD 6 M.2 drive and ran into the problem of it not being recognised as a boot drive when trying to boot from it, post installing a fresh copy of Windows on my system. I have checked a number of other threads with the same issue and followed their steps, but without any success. My motherboard is ASUS Z97 Pro Gamer, running Windows 10.

I started by unplugging my HDD and disk drive (heard it could cause issues) and then disabling CSM, setting Secure boot option to "other OS", then cleared the secure boot keys. Following that, I installed Windows from a prepared USB drive successfully onto my M.2 drive, unplugged the USB and then rebooted. This is when the message "The current BIOS setting do not fully support the boot device." appeared.

Ignoring this for now I continued following the steps by changing secure boot option back to "Windows UEFI mode" and installing the default secure boot keys. Despite doing all this my drive is still not recognised within the bios. I have tried redoing all the steps a number of times now without any luck.

Feels like my head is about to explode :/
Anyone know a solution to this problem?

Thank you!
 
Support for booting from NVMe storage was added in BIOS version 2103 and later.

Guide is found in this thread:
 

ASK THE COMMUNITY

TRENDING THREADS