• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

[SOLVED] Can't connect to NAS behind unmanaged switch

Dec 29, 2019
4
0
10
0
Hey guys,

I'm new to networking and set up my home network like this-
I have a tp-link modem/router. I connected an unmanaged tp-link switch to the LAN port on the router and connected a NAS and my PC to that switch.
I set up static IP's for my NAS and my computer and can access the internet on all devices (wired and wireless).
Whenever my laptop is connected directly to the switch I can access the NAS no problem. Whenever I disconnect and work on WiFi I can't access the NAS or even ping it.
Would love some insight to this issue.
Thanks
 
Dec 29, 2019
4
0
10
0
How have you set up your 'static' IPs? Did you actually hardcode them into your nas and computer, or did you do a dhcp reservation in your router?
I did both.
For my laptop I set it up as DHCP with manual address and put in the address I reserved for it. For my NAS I set it up as manual configuration and put in the IP address I reserved for it with the subnet, gateway and DNS.
In the router config I added the machines to the static IP lease list with the IP and MAC addresses
 
Dec 29, 2019
4
0
10
0
Check to make sure a option called wireless isolation it not turned on. If your router has the feature it is generally in the same screen with the other wifi settings.
I found the option for client isolation but it is turned off. I have another switch on my network that is connected to an Apple TV and I can ping in even on wifi so I guess the issue is either with the way I reserved the addresses or the switch itself because they are not the same model and not the wifi config
 
I did both.
For my laptop I set it up as DHCP with manual address and put in the address I reserved for it. For my NAS I set it up as manual configuration and put in the IP address I reserved for it with the subnet, gateway and DNS.
In the router config I added the machines to the static IP lease list with the IP and MAC addresses
I think this is the culprit. Do either statics or dhcp reservations, not both, and see if that fixes it.
 

ASK THE COMMUNITY