Question computer wont start after upgrading CPU and motherboard

Jul 29, 2019
2
0
10
0
I am upgrading my PC's CPU and motherboard to a ryzen 7 3700x and a asus Prime X570-p motherboard. This is my first time upgrading. after putting everything together and trying to boot the computer, all the components, IE, the GPU, CPU cooler, and motherboard's RGB light up except for my trident Z ram. the only things i can think of that would make any difference is that of the 8 pin and the 4 pin power connector on the top of the motherboard, the 8 pin connector is the only one that is plugged in to the PSU, because i read that it was the only one that is neccesary, and one of the pins broke in the USB 3.0 header on the motherboard but i also read that that wasn't much of a big deal.
my computer specs
Intel I5 6400 ---------> Ryzen 7 3700X
gigabyte B150M-D3h-----------> Asus Prime X570-P motherboard
Asus ROG OC GTX 1070
Gskill Trident Z RGB 2400MHz RAM
I'm not quite sure which PSU i have but i know it is 500W
and 1Tb HDD

does anyone have any suggestions as to what might be causing this to happen? perhaps one of the things i mensioned earlier, or a component incompatibility, or a general rookie mistake that people make on their first time?
anything helps! thank you
 

arif1752002m4a1

Commendable
May 16, 2018
647
3
1,315
102
You have to connect all 8pins to CPU connector(on top of motherboard).
And RAM will not light up until your Motherboard POSTs..

If your USB pin is shorted then you can easily remove that pin by using Wire Cutter...

Does mouse light up (bottom LED) .

Check If all components are working.
 

ASK THE COMMUNITY

TRENDING THREADS