Question Fps drops constantly after playing for a while

tonyle16062003

Prominent
Jul 7, 2018
3
0
510
0
So ive had this problem with my gaming laptop for months now and ive tried so many stuff but none of them worked, at this point im about to give up but i wanna try one last time here. Whenever i play games, the first 30-45 minutes will be very smooth but after that it stutters like hell, especially Overwatch, this also happens with other games but they take longer like 60-90 minutes. At first i saw that whenever the fps dropped the cpu temperature also dropped, so i figured my cpu was throttling (cpu temp when playin was 75-82, GPU temp was around 60). I decided to undervolt my cpu with throttlestop, temperatures dropped from 75-82 to 70-77 which im fine with however the problem didnt go away. Next thing i did was disabling turbo, which dropped my cpu temp to 68-75, this time whenever the fps dropped the temperature didnt really drop with it. Ive tried other things like disabling useless stuff like gamemode, gamedvr, windows update, choosing high performance power plan, changing nvidia settings for my gpu and none of them fixed it. I even reinstalled windows 10 but that didnt really do anythin. I did bring my laptop to a legit laptop service center and asked them to clean and repaste but that did absolutely nothin, heh sometimes i wonder if they even did those 2 things i asked for. Im just hoping someone can offer a solution. My specs:
Asus FX503VD
i5-7300HQ
GTX 1050
8GB DDR4
1TB SSHD
Windows 10
 
Last edited:

tonyle16062003

Prominent
Jul 7, 2018
3
0
510
0
This isn't reddit. So if you were expecting some abuse, I apologize now. :)

I'd say the more likely problem is GPU getting warm. Not sure what you can do in a laptop. That may be just typical of the beast since cooling things in such a dense package is at best a problem.
oh ahah im sorry, i was gonna post this on reddit but i made a new account so i needed to wait, i decided to copy the text and pasted it here. Anyway when i first bought the laptop it was still fine, and the gpu temperature is around 60, isnt that good? And its not even using my gpu that much, the gpu usage is only around 30 compared to my cpu which is around 80
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS